50e4500485fe283b66550a00f84537b50c7424a2
[platform/core/appfw/app-core.git] / packaging / app-core.spec
1 Name:       app-core
2 Summary:    Application basic
3 Version:        1.2
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    app-core-%{version}.tar.gz
8 BuildRequires:  pkgconfig(sensor)
9 BuildRequires:  pkgconfig(vconf)
10 BuildRequires:  pkgconfig(aul)
11 BuildRequires:  pkgconfig(rua)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(x11)
14 BuildRequires:  pkgconfig(sysman)
15 BuildRequires:  pkgconfig(elementary)
16 BuildRequires:  pkgconfig(ecore)
17 BuildRequires:  pkgconfig(ecore-x)
18 BuildRequires:  pkgconfig(gobject-2.0)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  cmake
21
22
23 %description
24 SLP common application basic
25
26
27
28 %package efl
29 Summary:    App basic EFL
30 Group:      Development/Libraries
31 Requires(post): /sbin/ldconfig
32 Requires(postun): /sbin/ldconfig
33
34 %description efl
35 Application basic EFL
36
37 %package efl-devel
38 Summary:    App basic EFL (devel)
39 Group:      Development/Libraries
40 Requires:   %{name}-efl = %{version}-%{release}
41 Requires:   %{name}-common-devel = %{version}-%{release}
42
43 %description efl-devel
44 Application basic EFL (devel)
45
46 %package common
47 Summary:    App basics common
48 Group:      Development/Libraries
49 Requires(post): /sbin/ldconfig
50 Requires(postun): /sbin/ldconfig
51
52 %description common
53 Application basics common
54
55 %package common-devel
56 Summary:    App basics common (devel)
57 Group:      Development/Libraries
58 Requires:   %{name}-common = %{version}-%{release}
59 Requires:   pkgconfig(sensor)
60 Requires:   pkgconfig(vconf)
61 Requires:   pkgconfig(elementary)
62 Requires:   pkgconfig(aul)
63
64 %description common-devel
65 Application basics common (devel)
66
67 %package template
68 Summary:    App basics template
69 Group:      Development/Libraries
70
71 %description template
72 Application basics template
73
74
75 %prep
76 %setup -q 
77
78 %build
79 CFLAGS="-I/usr/lib/glib-2.0/include/ -I/usr/include/glib-2.0 -I/usr/lib/dbus-1.0/include -I/usr/include/dbus-1.0 -I/usr/include/e_dbus-1 -I/usr/include/ethumb-0 -I/usr/include/edje-1 -I/usr/include/efreet-1 -I/usr/include/embryo-1 -I/usr/include/ecore-1 -I/usr/include/eet-1 -I/usr/include/evas-1 -I/usr/include/eina-1 -I/usr/include/eina-1/eina  $(CFLAGS)" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DENABLE_GTK=OFF
80
81 make %{?jobs:-j%jobs}
82
83 %install
84 %make_install
85
86
87 %post efl -p /sbin/ldconfig
88
89 %postun efl -p /sbin/ldconfig
90
91 %post common -p /sbin/ldconfig
92
93 %postun common -p /sbin/ldconfig
94
95
96
97
98 %files efl
99 %{_libdir}/libappcore-efl.so.*
100
101 %files efl-devel
102 %{_includedir}/appcore/appcore-efl.h
103 %{_libdir}/libappcore-efl.so
104 %{_libdir}/pkgconfig/appcore-efl.pc
105
106 %files common
107 %{_libdir}/libappcore-common.so.*
108
109 %files common-devel
110 %{_libdir}/libappcore-common.so
111 %{_libdir}/pkgconfig/appcore-common.pc
112 %{_includedir}/appcore/appcore-common.h
113 %{_includedir}/SLP_Appcore_PG.h
114
115