Add packaging
[platform/upstream/alure.git] / packaging / alure.spec
1 Name:           alure
2 Version:        1.2
3 Release:        0
4 License:        LGPL-2.0+
5 Summary:        File-loading and utility functions for OpenAL
6 Group:          System Environment/Libraries
7 URL:            http://kcat.strangesoft.net/alure.html
8 Group:          System/Libraries
9 Source:         %{name}-%{version}.tar.bz2
10 Source1001:     alure.manifest
11 BuildRequires:  cmake, libsndfile-devel, openal-soft-devel
12
13 %description
14 ALURE is a utility library to help manage common tasks with OpenAL applications
15
16 %package devel
17 Summary:        Development files for %{name}
18 Group:          Development/Libraries
19 # Devel doc includes some files under GPLv2+ from NaturalDocs
20 License:        LGPLv2+ and GPLv2+
21 Requires:       %{name} = %{version}
22 Requires:       pkgconfig
23
24 %description devel
25 ALURE is a utility library to help manage common tasks with OpenAL applications
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32
33 %cmake .
34 make %{?_smp_mflags}
35
36 %install
37 %make_install
38
39 %post -p /sbin/ldconfig
40
41 %postun -p /sbin/ldconfig
42
43
44 %files
45 %defattr(-,root,root,-)
46 %manifest %{name}.manifest
47 %license COPYING
48 %{_libdir}/libalure.so.*
49 %{_bindir}/alure*
50
51 %files devel
52 %defattr(-,root,root,-)
53 %manifest %{name}.manifest
54 /usr/share/doc/alure/html/*
55 %doc docs/html/* examples/*
56 %{_includedir}/AL/alure.h
57 %{_libdir}/*.so
58 %{_libdir}/pkgconfig/*.pc