Update /hal/etc/asound.conf to load as well
[platform/upstream/alsa-lib.git] / packaging / alsa-lib.spec
1 Name:           alsa-lib
2 Version:        1.0.29
3 Release:        4
4 License:        LGPL-2.1+
5 Summary:        The Advanced Linux Sound Architecture (ALSA) library
6 Url:            http://www.alsa-project.org/
7 Group:          System/Audio
8 Source0:        ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.bz2
9 Source1001:     alsa-lib.manifest
10 %define confdir /hal/share/alsa
11
12 %description
13 The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
14 functionality to the Linux operating system.
15
16 This package includes the ALSA runtime libraries to simplify application
17 programming and provide higher level functionality as well as support for
18 the older OSS API, providing binary compatibility for most OSS programs.
19
20 %package -n libasound
21 Summary:        ALSA Library package for multimedia framework middleware package
22 Group:          System/Audio
23
24 %description -n libasound
25 ALSA Library package for multimedia framework middleware package
26
27 %package -n libasound-devel
28 Summary:        ALSA Library package for multimedia framework middleware package
29 Group:          Development/Libraries
30 Requires:       libasound
31
32 %description -n libasound-devel
33 ALSA Library package for multimedia framework middleware package
34
35 %prep
36 %setup -q
37 cp %{SOURCE1001} .
38
39
40 %build
41 %reconfigure --disable-static \
42     --with-alsa-devdir=/dev/snd \
43     --disable-alisp \
44     --disable-python \
45     --with-gnu-ld \
46     --with-pcm-plugins=rate,route,linear,plug,dmix,dsnoop,asym,mmap,ioplug,null,empty \
47     --with-ucmdir=%{confdir}/ucm
48
49 make %{?_smp_mflags}
50
51 %install
52 %make_install
53
54 rm -f %{buildroot}/%{_bindir}/aserver
55
56 %post -n libasound -p /sbin/ldconfig
57
58 %postun -n libasound -p /sbin/ldconfig
59
60
61 %files -n libasound
62 %manifest %{name}.manifest
63 %defattr(-,root,root,-)
64 %license COPYING
65 %{_libdir}/lib*.so.*
66 %{_libdir}/alsa-lib/smixer/*.so
67 %{_datadir}/alsa/*
68
69 %files -n libasound-devel
70 %manifest %{name}.manifest
71 %defattr(-,root,root,-)
72 %{_includedir}/*
73 %{_libdir}/lib*.so
74 %{_libdir}/pkgconfig/*
75 %{_datadir}/aclocal
76