Cleanup
[external/alsa-lib.git] / packaging / alsa-lib.spec
1 Name:       alsa-lib
2 Summary:    The Advanced Linux Sound Architecture (ALSA) library
3 Version:    1.0.24.1
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://www.alsa-project.org/
8 Source0:    ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.gz
9
10
11 %description
12 The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
13 functionality to the Linux operating system.
14
15 This package includes the ALSA runtime libraries to simplify application
16 programming and provide higher level functionality as well as support for
17 the older OSS API, providing binary compatibility for most OSS programs.
18
19
20
21 %package -n libasound
22 Summary:    ALSA Library package for multimedia framework middleware package
23 Group:      Development/Libraries
24 Requires(post): /sbin/ldconfig
25 Requires(postun): /sbin/ldconfig
26
27 %description -n libasound
28 ALSA Library package for multimedia framework middleware package
29
30
31 %package -n libasound-devel
32 Summary:    ALSA Library package for multimedia framework middleware package
33 Group:      Development/Libraries
34 Requires:   libasound
35
36 %description -n libasound-devel
37 ALSA Library package for multimedia framework middleware package
38
39
40 %prep
41 %setup -q
42
43
44 %build
45 export CFLAGS+=" -fPIC" 
46 export LDFLAGS+=" -Wl,--warn-unresolved-symbols -Wl,--hash-style=both -Wl,--as-needed"
47 chmod +x autogen.sh
48
49 %autogen --disable-static
50 %configure --disable-static \
51 %ifarch %{arm}
52     --with-alsa-devdir=/dev/snd \
53 %endif
54 %ifarch %{arm}
55     --disable-alisp \
56 %endif
57 %ifarch %{arm}
58     --disable-seq \
59 %endif
60 %ifarch %{arm}
61     --disable-rawmidi \
62 %endif
63 %ifarch %{arm}
64     --disable-python \
65 %endif
66 %ifarch %{arm}
67     --with-gnu-ld \
68 %endif
69 %ifarch %{arm}
70     --with-pcm-plugins=rate,linear,plug,dmix,dsnoop,asym,mmap,ioplug
71 %endif
72
73 make %{?jobs:-j%jobs}
74
75 %install
76 rm -rf %{buildroot}
77 %make_install
78
79 rm -f %{buildroot}/%{_bindir}/aserver
80
81 %post -n libasound -p /sbin/ldconfig
82
83 %postun -n libasound -p /sbin/ldconfig
84
85 %files
86 %defattr(-,root,root,-)
87
88 %files -n libasound
89 %defattr(-,root,root,-)
90 %{_libdir}/lib*.so.*
91 %{_libdir}/alsa-lib/smixer/*.so
92 %{_datadir}/alsa/*
93
94 %files -n libasound-devel
95 %defattr(-,root,root,-)
96 %{_includedir}/*
97 %{_libdir}/lib*.so
98 %{_libdir}/pkgconfig/*
99 %{_datadir}/aclocal
100