2.0 init
[external/alsa-lib.git] / packaging / alsa-lib.spec
1 #sbs-git:slp/pkgs/a/alsa-lib alsa-lib 1.0.21a cb38cd61f9258cb9c7ea768f9782b372de5976df
2 Name:       alsa-lib
3 Summary:    The Advanced Linux Sound Architecture (ALSA) library
4 Version:    1.0.24.1
5 Release:    1
6 Group:      System/Libraries
7 License:    LGPLv2+
8 URL:        http://www.alsa-project.org/
9 Source0:    ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.gz
10
11
12 %description
13 The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
14 functionality to the Linux operating system.
15
16 This package includes the ALSA runtime libraries to simplify application
17 programming and provide higher level functionality as well as support for
18 the older OSS API, providing binary compatibility for most OSS programs.
19
20
21
22 %package -n libasound
23 Summary:    ALSA Library package for multimedia framework middleware package
24 Group:      Development/Libraries
25 Requires(post): /sbin/ldconfig
26 Requires(postun): /sbin/ldconfig
27
28 %description -n libasound
29 ALSA Library package for multimedia framework middleware package
30
31
32 %package -n libasound-devel
33 Summary:    ALSA Library package for multimedia framework middleware package
34 Group:      Development/Libraries
35 Requires:   libasound
36
37 %description -n libasound-devel
38 ALSA Library package for multimedia framework middleware package
39
40
41 %prep
42 %setup -q
43
44
45 %build
46 export CFLAGS+=" -fPIC" 
47 export LDFLAGS+=" -Wl,--warn-unresolved-symbols -Wl,--hash-style=both -Wl,--as-needed"
48 chmod +x autogen.sh
49
50 %autogen --disable-static
51 %configure --disable-static \
52 %ifarch %{arm}
53     --with-alsa-devdir=/dev/snd \
54 %endif
55 %ifarch %{arm}
56     --disable-alisp \
57 %endif
58 %ifarch %{arm}
59     --disable-seq \
60 %endif
61 %ifarch %{arm}
62     --disable-rawmidi \
63 %endif
64 %ifarch %{arm}
65     --disable-python \
66 %endif
67 %ifarch %{arm}
68     --with-gnu-ld \
69 %endif
70 %ifarch %{arm}
71     --with-pcm-plugins=rate,linear,plug,dmix,dsnoop,asym,mmap,ioplug
72 %endif
73
74 make %{?jobs:-j%jobs}
75
76 %install
77 rm -rf %{buildroot}
78 %make_install
79
80 rm -f %{buildroot}/%{_bindir}/aserver
81
82 %post -n libasound -p /sbin/ldconfig
83
84 %postun -n libasound -p /sbin/ldconfig
85
86 %files
87 %defattr(-,root,root,-)
88
89 %files -n libasound
90 %defattr(-,root,root,-)
91 %{_libdir}/lib*.so.*
92 %{_libdir}/alsa-lib/smixer/*.so
93 %{_datadir}/alsa/*
94
95 %files -n libasound-devel
96 %defattr(-,root,root,-)
97 %{_includedir}/*
98 %{_libdir}/lib*.so
99 %{_libdir}/pkgconfig/*
100 %{_datadir}/aclocal
101