Enable route plugin to handle unsupported channel count
[platform/upstream/alsa-lib.git] / packaging / alsa-lib.spec
1 Name:           alsa-lib
2 Version:        1.0.28
3 Release:        6
4 License:        LGPL-2.1+
5 Summary:        The Advanced Linux Sound Architecture (ALSA) library
6 Url:            http://www.alsa-project.org/
7 Group:          System/Audio
8 Source0:        ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.bz2
9 Source1001:     alsa-lib.manifest
10
11 %description
12 The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
13 functionality to the Linux operating system.
14
15 This package includes the ALSA runtime libraries to simplify application
16 programming and provide higher level functionality as well as support for
17 the older OSS API, providing binary compatibility for most OSS programs.
18
19 %package -n libasound
20 Summary:        ALSA Library package for multimedia framework middleware package
21 Group:          System/Audio
22
23 %description -n libasound
24 ALSA Library package for multimedia framework middleware package
25
26 %package -n libasound-devel
27 Summary:        ALSA Library package for multimedia framework middleware package
28 Group:          Development/Libraries
29 Requires:       libasound
30
31 %description -n libasound-devel
32 ALSA Library package for multimedia framework middleware package
33
34 %prep
35 %setup -q
36 cp %{SOURCE1001} .
37
38
39 %build
40 %configure --disable-static \
41     --with-alsa-devdir=/dev/snd \
42     --disable-alisp \
43     --disable-python \
44     --with-gnu-ld \
45     --with-pcm-plugins=rate,route,linear,plug,dmix,dsnoop,asym,mmap,ioplug,null,empty
46
47 make %{?_smp_mflags}
48
49 %install
50 %make_install
51
52 rm -f %{buildroot}/%{_bindir}/aserver
53
54 %post -n libasound -p /sbin/ldconfig
55
56 %postun -n libasound -p /sbin/ldconfig
57
58
59 %files -n libasound
60 %manifest %{name}.manifest
61 %defattr(-,root,root,-)
62 %license COPYING
63 %{_libdir}/lib*.so.*
64 %{_libdir}/alsa-lib/smixer/*.so
65 %{_datadir}/alsa/*
66
67 %files -n libasound-devel
68 %manifest %{name}.manifest
69 %defattr(-,root,root,-)
70 %{_includedir}/*
71 %{_libdir}/lib*.so
72 %{_libdir}/pkgconfig/*
73 %{_datadir}/aclocal
74