cleanup specfile for packaging
[profile/ivi/alsa-lib.git] / packaging / alsa-lib.spec
1 Name:       alsa-lib
2 Summary:    The Advanced Linux Sound Architecture (ALSA) library
3 Version:    1.0.25
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://www.alsa-project.org/
8 Source0:    %{name}-%{version}.tar.bz2
9
10
11 %description
12 The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
13 functionality to the Linux operating system.
14
15 This package includes the ALSA runtime libraries to simplify application
16 programming and provide higher level functionality as well as support for
17 the older OSS API, providing binary compatibility for most OSS programs.
18
19
20
21 %package -n libasound
22 Summary:    ALSA Library package for multimedia framework middleware package
23 Group:      Development/Libraries
24 Requires(post): /sbin/ldconfig
25 Requires(postun): /sbin/ldconfig
26
27 %description -n libasound
28 ALSA Library package for multimedia framework middleware package
29
30
31 %package -n libasound-devel
32 Summary:    ALSA Library package for multimedia framework middleware package
33 Group:      Development/Libraries
34 Requires:   libasound
35
36 %description -n libasound-devel
37 ALSA Library package for multimedia framework middleware package
38
39
40 %prep
41 %setup -q -n %{name}-%{version}
42
43 %build
44 export CFLAGS+=" -fPIC" 
45 export LDFLAGS+=" -Wl,--warn-unresolved-symbols -Wl,--hash-style=both -Wl,--as-needed"
46
47 %ifarch %arm
48 %configure \
49     --with-alsa-devdir=/dev/snd \
50     --disable-alisp \
51     --disable-seq \
52     --disable-rawmidi \
53     --disable-python \
54     --with-gnu-ld \
55     --with-pcm-plugins=rate,linear,plug,dmix,dsnoop,asym,mmap,ioplug,hooks
56 %else
57 %configure
58 %endif
59
60 make %{?jobs:-j%jobs}
61
62 %install
63 rm -rf %{buildroot}
64 %make_install
65
66 rm -f %{buildroot}/%{_bindir}/aserver
67
68 %post -n libasound -p /sbin/ldconfig
69
70 %postun -n libasound -p /sbin/ldconfig
71
72 %files
73
74 %files -n libasound
75 %{_libdir}/lib*.so.*
76 %{_libdir}/alsa-lib/smixer/*.so
77 %{_datadir}/alsa/*
78
79 %files -n libasound-devel
80 %{_includedir}/*
81 %{_libdir}/lib*.so
82 %{_libdir}/pkgconfig/*
83 %{_datadir}/aclocal