Git init
[framework/base/acl.git] / packaging / acl.spec
1 Name:           acl
2 Version:        2.2.49
3 Release:        1
4 License:        GPLv2
5 Summary:        Access control list utilities
6 Url:            http://savannah.nongnu.org/projects/acl
7 Group:          System/Base
8 Source:         http://download.savannah.gnu.org/releases/acl/acl-%{version}.src.tar.gz
9
10 # SLP patches
11 Patch0: 01-Makefile.patch
12 Patch1: 03-re-stat_file_after_chown.patch
13 Patch2: 04-print_useful_error_from_read_acl_comments.patch
14 Patch3: 05-restore_crash_on_malformed_input.patch
15 Patch4: 06-fix_potential_null_pointer_dereference.patch
16 Patch5: 02-499076-physical-walk.patch
17 Patch6: 09-prevent_setfacl_--restore_from_SIGSEGV.patch
18
19 BuildRequires:  libattr-devel >= 2.4.1
20 BuildRequires:  gettext-tools
21
22 %description
23 This package contains the getfacl and setfacl utilities needed for
24 manipulating access control lists.
25
26 %package -n libacl
27 License:        LGPLv2.1
28 Summary:        Dynamic library for access control list support
29 Group:          System/Libraries
30 Requires(post): /sbin/ldconfig
31 Requires(postun): /sbin/ldconfig
32
33 %description -n libacl
34 This package contains the libacl.so dynamic library which contains
35 the POSIX 1003.1e draft standard 17 functions for manipulating access
36 control lists.
37
38 %package -n libacl-devel
39 License:        LGPL
40 Summary:        Access control list static libraries and headers
41 Group:          Development/Libraries
42 Requires:       libacl = %{version}
43 Requires:       libattr-devel
44
45 %description -n libacl-devel
46 This package contains static libraries and header files needed to develop
47 programs which make use of the access control list programming interface
48 defined in POSIX 1003.1e draft standard 17.
49
50 %prep
51 %setup -q
52 %patch0 -p1 
53 %patch1 -p1 
54 %patch2 -p1 
55 %patch3 -p1 
56 %patch4 -p1 
57 %patch5 -p1 
58 %patch6 -p1 
59
60 %build
61 export INSTALL_USER=root INSTALL_GROUP=root
62 make configure
63 make default
64 cd po; rm -rf acl.pot; make acl.pot
65
66 %install
67 DIST_ROOT=%{buildroot} make -C . install
68 DIST_ROOT=%{buildroot} make -C . install-dev
69 DIST_ROOT=%{buildroot} make -C . install-lib
70 DIST_ROOT=%{buildroot} make -C build src-manifest
71
72 rm -f %{buildroot}/lib/*.a
73 rm -f %{buildroot}/lib/*.la
74 rm -rf %{buildroot}%{_defaultdocdir}
75
76 # fix links to shared libs and permissions
77 rm -f %{buildroot}/%{_libdir}/libacl.so
78 ln -sf ../../%{_lib}/libacl.so %{buildroot}/%{_libdir}/libacl.so
79 chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
80
81 %post -n libacl -p /sbin/ldconfig
82
83 %postun -n libacl -p /sbin/ldconfig
84
85
86 %docs_package
87
88 %files
89 %{_bindir}/chacl
90 %{_bindir}/getfacl
91 %{_bindir}/setfacl
92 %{_prefix}/share/locale/*/LC_MESSAGES/*.mo
93
94 %files -n libacl-devel
95 /%{_lib}/libacl.so
96 %{_includedir}/acl
97 %{_includedir}/sys/acl.h
98 %{_libdir}/libacl.*
99
100 %files -n libacl
101 /%{_lib}/libacl.so.*