Initial commit
[profile/ivi/SettingsApp.git] / packaging / Settings.spec
1 Name:       Settings
2 Summary:    A HTML5 based app for system settings
3 Version:    0.0.1
4 Release:    1
5 Group:      Applications/Web Applications
6 License:    Apache-2.0
7 URL:        http://www.tizen.org2
8 Source0:    %{name}-%{version}.tar.bz2
9 BuildRequires:  zip
10 BuildRequires:  desktop-file-utils
11 Requires:   wrt-installer
12 Requires:   bluetooth-frwk-core
13 Requires:   bluetooth-frwk-service
14
15 %description
16 A HTML5 based app for system settings like WiFi, Bluetooth
17
18 %prep
19 %setup -q -n %{name}-%{version}
20
21 %build
22
23 make wgtPkg
24
25 #make %{?jobs:-j%jobs}
26
27 %install
28 rm -rf %{buildroot}
29 %make_install
30
31 %post
32 if [ -f /opt/usr/apps/.preinstallWidgets/preinstallDone ]; then
33     wrt-installer -i /opt/usr/apps/.preinstallWidgets/Settings.wgt;
34 fi
35
36 %files
37 %defattr(-,root,root,-)
38 /opt/usr/apps/.preinstallWidgets/Settings.wgt