Revert "Fixes TIVI-2064"
[profile/ivi/SettingsApp.git] / packaging / Settings.spec
1 Name:       Settings
2 Summary:    A HTML5 based app for system settings
3 Version:    0.0.2
4 Release:    1
5 Group:      Applications/Web Applications
6 License:    Apache-2.0
7 URL:        http://www.tizen.org2
8 Source0:    %{name}-%{version}.tar.bz2
9 BuildRequires:  zip
10 BuildRequires:  desktop-file-utils
11 Requires:   bluetooth-frwk-core
12 Requires:   bluetooth-frwk-service
13 Requires:   settingsd
14 Requires:   wrt-installer
15
16 %description
17 A HTML5 based app for system settings like WiFi, Bluetooth
18
19 %prep
20 %setup -q -n %{name}-%{version}
21
22 %build
23
24 make wgtPkg
25
26 #make %{?jobs:-j%jobs}
27
28 %install
29 rm -rf %{buildroot}
30 %make_install
31
32 %post
33 if [ -f /opt/usr/apps/.preinstallWidgets/preinstallDone ]; then
34     wrt-installer -i /opt/usr/apps/.preinstallWidgets/Settings.wgt;
35 fi
36
37 %postun
38 wrt-installer -un ODBQpKvkS1.Settings
39
40 %files
41 %defattr(-,root,root,-)
42 /opt/usr/apps/.preinstallWidgets/Settings.wgt