upgrade SDL to version 2.0.8
[platform/upstream/SDL.git] / packaging / SDL2.spec
1 Summary: Simple DirectMedia Layer
2 Name: SDL2
3 Version: 2.0.8
4 Release: 2
5 Source: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
6 URL: http://www.libsdl.org/
7 License: Zlib and SGI-B-2.0
8 Group: System Environment/Libraries
9 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
10 Prefix: %{_prefix}
11 %ifos linux
12 Provides: libSDL2-2.0.so.0
13 %endif
14
15 %define _unpackaged_files_terminate_build 0
16 %define __defattr %defattr(-,root,root)
17 %define __soext so
18
19 Requires(post): /sbin/ldconfig
20 Requires(postun): /sbin/ldconfig
21 BuildRequires:  pkgconfig(egl)
22 BuildRequires:  pkgconfig(glesv2)
23 BuildRequires:  pkgconfig(wayland-client)
24 BuildRequires:  pkgconfig(wayland-cursor)
25 BuildRequires:  pkgconfig(wayland-egl)
26 BuildRequires:  pkgconfig(wayland-egl-tizen)
27 BuildRequires:  pkgconfig(text-client)
28 BuildRequires:  pkgconfig(tizen-extension-client)
29 BuildRequires:  pkgconfig(tizen-remote-surface-client)
30 BuildRequires:  pkgconfig(wayland-tbm-client)
31 Requires:       libwayland-extension-client
32 BuildRequires:  pkgconfig(xkbcommon)
33 BuildRequires:  pkgconfig(libpng)
34 BuildRequires:  pkgconfig(libxml-2.0)
35 BuildRequires:  pkgconfig(pixman-1)
36 BuildRequires:  pkgconfig(freetype2)
37 BuildRequires:  pkgconfig(fontconfig)
38 BuildRequires:  pkgconfig(glib-2.0)
39 BuildRequires:  pkgconfig(libdrm)
40 BuildRequires:  pkgconfig(ecore-ipc)
41 BuildRequires:  binutils-devel
42 BuildRequires:  which
43 BuildRequires:  autoconf
44 BuildRequires:  pkgconfig(ecore)
45 BuildRequires:  pkgconfig(ecore-wl2)
46 BuildRequires:  pkgconfig(appcore-common)
47 BuildRequires:  pkgconfig(capi-appfw-application)
48 BuildRequires:  pkgconfig(capi-system-system-settings)
49 BuildRequires:  pkgconfig(dlog)
50 BuildRequires:  pkgconfig(ecore-imf)
51 BuildRequires:  pkgconfig(aul)
52 BuildRequires:  pkgconfig(elementary)
53 BuildRequires:  pkgconfig(libpulse)
54 BuildRequires:  terminfo-base-mini
55 BuildRequires:  Vulkan-LoaderAndValidationLayers
56 BuildRequires:  Vulkan-LoaderAndValidationLayers-devel
57
58 %description
59 This is the Simple DirectMedia Layer, a generic API that provides low
60 level access to audio, keyboard, mouse, and display framebuffer across
61 multiple platforms.
62
63 %package devel
64 Summary: Libraries, includes and more to develop SDL applications.
65 Group: Development/Libraries
66 Requires: %{name} = %{version}
67
68 %description devel
69 This is the Simple DirectMedia Layer, a generic API that provides low
70 level access to audio, keyboard, mouse, and display framebuffer across
71 multiple platforms.
72
73 This is the libraries, include files and other resources you can use
74 to develop SDL applications.
75
76
77 %prep
78 %setup -q
79
80 %build
81 cd src/video/tizen/indicator
82 make #%{?_smp_mflgs}
83
84 cd ../../../../
85 %if "%{asan}" == "1"
86 %restore_fcommon
87 LDFLAGS+=" -lasan -ldl "
88 %endif
89 %ifos linux
90 CFLAGS="$RPM_OPT_FLAGS" %configure --prefix=%{prefix} --disable-video-directfb --disable-video-wayland --enable-video-tizen %{?asan:--disable-assembly}
91 %else
92 %configure %{?asan:--disable-assembly}
93 %endif
94 make
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %ifos linux
99 cd src/video/tizen/indicator
100 make install DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_bindir}
101
102 cd ../../../../
103 make install prefix=$RPM_BUILD_ROOT%{prefix} \
104              bindir=$RPM_BUILD_ROOT%{_bindir} \
105              libdir=$RPM_BUILD_ROOT%{_libdir} \
106              includedir=$RPM_BUILD_ROOT%{_includedir} \
107              datadir=$RPM_BUILD_ROOT%{_datadir} \
108              mandir=$RPM_BUILD_ROOT%{_mandir}
109 %else
110 %makeinstall
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 /usr/bin/sdl_indicator
118 %manifest SDL2.manifest
119 %{__defattr}
120 %license COPYING.txt
121 #%doc README*.txt COPYING.txt CREDITS.txt BUGS.txt
122 %{_libdir}/lib*.%{__soext}.*
123
124 %files devel
125 %{__defattr}
126 #%doc docs/README*.md
127 %{_bindir}/*-config
128 %{_libdir}/lib*.a
129 %{_libdir}/lib*.la
130 %{_libdir}/lib*.%{__soext}
131 %{_includedir}/*/*.h
132 %{_libdir}/pkgconfig/*
133 %{_datadir}/aclocal/*
134
135 %changelog
136 * Thu Jun 04 2015 Ryan C. Gordon <icculus@icculus.org>
137 - Fixed README paths.
138
139 * Sun Dec 07 2014 Simone Contini <s.contini@oltrelinux.com>
140 - Fixed changelog date issue and docs filenames
141
142 * Sun Jan 22 2012 Sam Lantinga <slouken@libsdl.org>
143 - Updated for SDL 2.0
144
145 * Tue May 16 2006 Sam Lantinga <slouken@libsdl.org>
146 - Removed support for Darwin, due to build problems on ps2linux
147
148 * Sat Jan 03 2004 Anders Bjorklund <afb@algonet.se>
149 - Added support for Darwin, updated spec file
150
151 * Wed Jan 19 2000 Sam Lantinga <slouken@libsdl.org>
152 - Re-integrated spec file into SDL distribution
153 - 'name' and 'version' come from configure
154 - Some of the documentation is devel specific
155 - Removed SMP support from %build - it doesn't work with libtool anyway
156
157 * Tue Jan 18 2000 Hakan Tandogan <hakan@iconsult.com>
158 - Hacked Mandrake sdl spec to build 1.1
159
160 * Sun Dec 19 1999 John Buswell <johnb@mandrakesoft.com>
161 - Build Release
162
163 * Sat Dec 18 1999 John Buswell <johnb@mandrakesoft.com>
164 - Add symlink for libSDL-1.0.so.0 required by sdlbomber
165 - Added docs
166
167 * Thu Dec 09 1999 Lenny Cartier <lenny@mandrakesoft.com>
168 - v 1.0.0
169
170 * Mon Nov  1 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
171 - First spec file for Mandrake distribution.
172
173 # end of file