Merge "[SDL_Tizen] Add SDL_Window function" into tizen
[platform/upstream/SDL.git] / packaging / SDL2.spec
1 Summary: Simple DirectMedia Layer
2 Name: SDL2
3 Version: 2.0.4
4 Release: 2
5 Source: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
6 URL: http://www.libsdl.org/
7 License: Zlib and SGI-B-2.0
8 Group: System Environment/Libraries
9 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
10 Prefix: %{_prefix}
11 %ifos linux
12 Provides: libSDL2-2.0.so.0
13 %endif
14
15
16
17 %define _unpackaged_files_terminate_build 0
18
19
20 %define __defattr %defattr(-,root,root)
21 %define __soext so
22
23 Requires(post): /sbin/ldconfig
24 Requires(postun): /sbin/ldconfig
25 BuildRequires:  pkgconfig(egl)
26 BuildRequires:  pkgconfig(glesv2)
27 BuildRequires:  pkgconfig(wayland-client)
28 BuildRequires:  pkgconfig(wayland-cursor)
29 BuildRequires:  pkgconfig(wayland-egl)
30 BuildRequires:  pkgconfig(text-client)
31 BuildRequires:  pkgconfig(xdg-shell-client)
32 BuildRequires:  pkgconfig(tizen-extension-client)
33 BuildRequires:  pkgconfig(tizen-remote-surface-client)
34 BuildRequires:  pkgconfig(wayland-tbm-client)
35 Requires:       libwayland-extension-client
36 BuildRequires:  pkgconfig(xkbcommon)
37 BuildRequires:  pkgconfig(libpng)
38 BuildRequires:  pkgconfig(libxml-2.0)
39 BuildRequires:  pkgconfig(pixman-1)
40 BuildRequires:  pkgconfig(freetype2)
41 BuildRequires:  pkgconfig(fontconfig)
42 BuildRequires:  pkgconfig(glib-2.0)
43 BuildRequires:  pkgconfig(libdrm)
44 BuildRequires:  pkgconfig(ecore-ipc)
45 BuildRequires:  binutils-devel
46 BuildRequires:  which
47 BuildRequires:  autoconf
48 BuildRequires:  pkgconfig(ecore)
49 BuildRequires:  pkgconfig(ecore-wayland)
50 BuildRequires:  pkgconfig(capi-appfw-application)
51 BuildRequires:  pkgconfig(capi-system-system-settings)
52 BuildRequires:  pkgconfig(dlog)
53 BuildRequires:  pkgconfig(ecore-imf)
54 BuildRequires:  pkgconfig(aul)
55 #BuildRequires:  Vulkan-LoaderAndValidationLayers
56 #BuildRequires:  Vulkan-LoaderAndValidationLayers-devel
57
58 %description
59 This is the Simple DirectMedia Layer, a generic API that provides low
60 level access to audio, keyboard, mouse, and display framebuffer across
61 multiple platforms.
62
63 %package devel
64 Summary: Libraries, includes and more to develop SDL applications.
65 Group: Development/Libraries
66 Requires: %{name} = %{version}
67
68 %description devel
69 This is the Simple DirectMedia Layer, a generic API that provides low
70 level access to audio, keyboard, mouse, and display framebuffer across
71 multiple platforms.
72
73 This is the libraries, include files and other resources you can use
74 to develop SDL applications.
75
76
77 %prep
78 %setup -q
79
80 %build
81 %if "%{asan}" == "1"
82 %restore_fcommon
83 LDFLAGS+=" -lasan -ldl "
84 %endif
85 %ifos linux
86 CFLAGS="$RPM_OPT_FLAGS" %configure --prefix=%{prefix} --disable-video-directfb --enable-video-tizen %{?asan:--disable-assembly}
87 %else
88 %configure %{?asan:--disable-assembly}
89 %endif
90 make
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %ifos linux
95 make install prefix=$RPM_BUILD_ROOT%{prefix} \
96              bindir=$RPM_BUILD_ROOT%{_bindir} \
97              libdir=$RPM_BUILD_ROOT%{_libdir} \
98              includedir=$RPM_BUILD_ROOT%{_includedir} \
99              datadir=$RPM_BUILD_ROOT%{_datadir} \
100              mandir=$RPM_BUILD_ROOT%{_mandir}
101 %else
102 %makeinstall
103 %endif
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %manifest SDL2.manifest
110 %{__defattr}
111 %license COPYING
112 #%doc README*.txt COPYING.txt CREDITS.txt BUGS.txt
113 %{_libdir}/lib*.%{__soext}.*
114
115 %files devel
116 %{__defattr}
117 #%doc docs/README*.md
118 %{_bindir}/*-config
119 %{_libdir}/lib*.a
120 %{_libdir}/lib*.la
121 %{_libdir}/lib*.%{__soext}
122 %{_includedir}/*/*.h
123 %{_libdir}/pkgconfig/*
124 %{_datadir}/aclocal/*
125
126 %changelog
127 * Thu Jun 04 2015 Ryan C. Gordon <icculus@icculus.org>
128 - Fixed README paths.
129
130 * Sun Dec 07 2014 Simone Contini <s.contini@oltrelinux.com>
131 - Fixed changelog date issue and docs filenames
132
133 * Sun Jan 22 2012 Sam Lantinga <slouken@libsdl.org>
134 - Updated for SDL 2.0
135
136 * Tue May 16 2006 Sam Lantinga <slouken@libsdl.org>
137 - Removed support for Darwin, due to build problems on ps2linux
138
139 * Sat Jan 03 2004 Anders Bjorklund <afb@algonet.se>
140 - Added support for Darwin, updated spec file
141
142 * Wed Jan 19 2000 Sam Lantinga <slouken@libsdl.org>
143 - Re-integrated spec file into SDL distribution
144 - 'name' and 'version' come from configure
145 - Some of the documentation is devel specific
146 - Removed SMP support from %build - it doesn't work with libtool anyway
147
148 * Tue Jan 18 2000 Hakan Tandogan <hakan@iconsult.com>
149 - Hacked Mandrake sdl spec to build 1.1
150
151 * Sun Dec 19 1999 John Buswell <johnb@mandrakesoft.com>
152 - Build Release
153
154 * Sat Dec 18 1999 John Buswell <johnb@mandrakesoft.com>
155 - Add symlink for libSDL-1.0.so.0 required by sdlbomber
156 - Added docs
157
158 * Thu Dec 09 1999 Lenny Cartier <lenny@mandrakesoft.com>
159 - v 1.0.0
160
161 * Mon Nov  1 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
162 - First spec file for Mandrake distribution.
163
164 # end of file