Add indicator
[platform/upstream/SDL.git] / packaging / SDL2.spec
1 Summary: Simple DirectMedia Layer
2 Name: SDL2
3 Version: 2.0.4
4 Release: 2
5 Source: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
6 URL: http://www.libsdl.org/
7 License: Zlib and SGI-B-2.0
8 Group: System Environment/Libraries
9 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
10 Prefix: %{_prefix}
11 %ifos linux
12 Provides: libSDL2-2.0.so.0
13 %endif
14
15
16
17 %define _unpackaged_files_terminate_build 0
18
19
20 %define __defattr %defattr(-,root,root)
21 %define __soext so
22
23 Requires(post): /sbin/ldconfig
24 Requires(postun): /sbin/ldconfig
25 BuildRequires:  pkgconfig(egl)
26 BuildRequires:  pkgconfig(glesv2)
27 BuildRequires:  pkgconfig(wayland-client)
28 BuildRequires:  pkgconfig(wayland-cursor)
29 BuildRequires:  pkgconfig(wayland-egl)
30 BuildRequires:  pkgconfig(text-client)
31 BuildRequires:  pkgconfig(xdg-shell-client)
32 BuildRequires:  pkgconfig(tizen-extension-client)
33 Requires:       libwayland-extension-client
34 BuildRequires:  pkgconfig(xkbcommon)
35 BuildRequires:  pkgconfig(libpng)
36 BuildRequires:  pkgconfig(libxml-2.0)
37 BuildRequires:  pkgconfig(pixman-1)
38 BuildRequires:  pkgconfig(freetype2)
39 BuildRequires:  pkgconfig(fontconfig)
40 BuildRequires:  pkgconfig(glib-2.0)
41 BuildRequires:  pkgconfig(libdrm)
42 BuildRequires:  pkgconfig(ecore-ipc)
43 BuildRequires:  binutils-devel
44 BuildRequires:  which
45 BuildRequires:  autoconf
46 BuildRequires:  pkgconfig(ecore)
47 BuildRequires:  pkgconfig(ecore-wayland)
48 BuildRequires:  pkgconfig(capi-appfw-application)
49 BuildRequires:  pkgconfig(capi-system-system-settings)
50 BuildRequires:  pkgconfig(dlog)
51 BuildRequires:  pkgconfig(ecore-imf)
52 BuildRequires:  pkgconfig(aul)
53
54 %if "%{profile}" == "mobile"
55 BuildRequires:  Vulkan-LoaderAndValidationLayers
56 BuildRequires:  Vulkan-LoaderAndValidationLayers-devel
57 %endif
58
59 %description
60 This is the Simple DirectMedia Layer, a generic API that provides low
61 level access to audio, keyboard, mouse, and display framebuffer across
62 multiple platforms.
63
64 %package devel
65 Summary: Libraries, includes and more to develop SDL applications.
66 Group: Development/Libraries
67 Requires: %{name} = %{version}
68
69 %description devel
70 This is the Simple DirectMedia Layer, a generic API that provides low
71 level access to audio, keyboard, mouse, and display framebuffer across
72 multiple platforms.
73
74 This is the libraries, include files and other resources you can use
75 to develop SDL applications.
76
77
78 %prep
79 %setup -q
80
81 %build
82 %if "%{asan}" == "1"
83 %restore_fcommon
84 LDFLAGS+=" -lasan -ldl "
85 %endif
86 %ifos linux
87 CFLAGS="$RPM_OPT_FLAGS" %configure --prefix=%{prefix} --disable-video-directfb --enable-video-tizen %{?asan:--disable-assembly}
88 %else
89 %configure %{?asan:--disable-assembly}
90 %endif
91 make
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %ifos linux
96 make install prefix=$RPM_BUILD_ROOT%{prefix} \
97              bindir=$RPM_BUILD_ROOT%{_bindir} \
98              libdir=$RPM_BUILD_ROOT%{_libdir} \
99              includedir=$RPM_BUILD_ROOT%{_includedir} \
100              datadir=$RPM_BUILD_ROOT%{_datadir} \
101              mandir=$RPM_BUILD_ROOT%{_mandir}
102 %else
103 %makeinstall
104 %endif
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %manifest SDL2.manifest
111 %{__defattr}
112 #%doc README*.txt COPYING.txt CREDITS.txt BUGS.txt
113 %{_libdir}/lib*.%{__soext}.*
114
115 %files devel
116 %{__defattr}
117 #%doc docs/README*.md
118 %{_bindir}/*-config
119 %{_libdir}/lib*.a
120 %{_libdir}/lib*.la
121 %{_libdir}/lib*.%{__soext}
122 %{_includedir}/*/*.h
123 %{_libdir}/pkgconfig/*
124 %{_datadir}/aclocal/*
125
126 %changelog
127 * Thu Jun 04 2015 Ryan C. Gordon <icculus@icculus.org>
128 - Fixed README paths.
129
130 * Sun Dec 07 2014 Simone Contini <s.contini@oltrelinux.com>
131 - Fixed changelog date issue and docs filenames
132
133 * Sun Jan 22 2012 Sam Lantinga <slouken@libsdl.org>
134 - Updated for SDL 2.0
135
136 * Tue May 16 2006 Sam Lantinga <slouken@libsdl.org>
137 - Removed support for Darwin, due to build problems on ps2linux
138
139 * Sat Jan 03 2004 Anders Bjorklund <afb@algonet.se>
140 - Added support for Darwin, updated spec file
141
142 * Wed Jan 19 2000 Sam Lantinga <slouken@libsdl.org>
143 - Re-integrated spec file into SDL distribution
144 - 'name' and 'version' come from configure
145 - Some of the documentation is devel specific
146 - Removed SMP support from %build - it doesn't work with libtool anyway
147
148 * Tue Jan 18 2000 Hakan Tandogan <hakan@iconsult.com>
149 - Hacked Mandrake sdl spec to build 1.1
150
151 * Sun Dec 19 1999 John Buswell <johnb@mandrakesoft.com>
152 - Build Release
153
154 * Sat Dec 18 1999 John Buswell <johnb@mandrakesoft.com>
155 - Add symlink for libSDL-1.0.so.0 required by sdlbomber
156 - Added docs
157
158 * Thu Dec 09 1999 Lenny Cartier <lenny@mandrakesoft.com>
159 - v 1.0.0
160
161 * Mon Nov  1 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
162 - First spec file for Mandrake distribution.
163
164 # end of file