Stripped the old yaml stuff out of the spec file
[profile/ivi/GUPnP.git] / packaging / GUPnP.spec
1 Name:       gupnp
2 Summary:    GUPnP is an framework for creating UPnP devices & control points
3 Version:    0.20.3
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://www.gupnp.org/
8 Source0:    http://download.gnome.org/sources/%{name}/0.20/%{name}-%{version}.tar.bz2
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gio-2.0)
13 BuildRequires:  pkgconfig(gmodule-2.0)
14 BuildRequires:  pkgconfig(gssdp-1.0)
15 BuildRequires:  pkgconfig(libsoup-2.4)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(uuid)
18
19
20 %description
21 GUPnP is an object-oriented open source framework for creating UPnP 
22 devices and control points, written in C using GObject and libsoup. 
23 The GUPnP API is intended to be easy to use, efficient and flexible.
24
25 %package devel
26 Summary:    Development package for gupnp
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 Files for development with gupnp.
32
33 %prep
34 %setup -q -n %{name}-%{version}
35
36 %build
37 %configure --disable-static
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 rm -rf  $RPM_BUILD_ROOT%{_datadir}/gtk-doc
45
46 %post -p /sbin/ldconfig
47
48 %postun -p /sbin/ldconfig
49
50 %files
51 %defattr(-,root,root,-)
52 %{_libdir}/*.so.*
53
54 %files devel
55 %defattr(-,root,root,-)
56 %{_libdir}/pkgconfig/gupnp-1.0.pc
57 %{_libdir}/*.so
58 %{_includedir}/gupnp-1.0
59 %{_bindir}/gupnp-binding-tool