Add gobject introspection
[profile/ivi/GUPnP-AV.git] / packaging / GUPnP-AV.spec
1 Name:       gupnp-av
2 Summary:    GUPnP-AV is a collection of helpers for building UPnP AV applications
3 Version:    0.12.4
4 Release:    0
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://www.gupnp.org/
8 Source0:    http://download.gnome.org/sources/%{name}/0.12/%{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(gupnp-1.0)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(gobject-2.0)
14 BuildRequires:  pkgconfig(libxml-2.0)
15 BuildRequires:  gobject-introspection-devel
16 BuildRequires:  vala
17
18
19 %description
20 GUPnP is an object-oriented open source framework for creating UPnP
21 devices and control points, written in C using GObject and libsoup.
22 The GUPnP API is intended to be easy to use, efficient and flexible.
23
24 GUPnP-AV is a collection of helpers for building AV (audio/video)
25 applications using GUPnP.
26
27 %package devel
28 Summary:    Development package for gupnp-av
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 Files for development with gupnp-av.
34
35
36 %prep
37 %setup -q -n %{name}-%{version}
38
39 %build
40 %configure --disable-static
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47 rm -rf  $RPM_BUILD_ROOT%{_datadir}/gtk-doc
48
49 %post -p /sbin/ldconfig
50
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(-,root,root,-)
55 %doc AUTHORS COPYING README
56 %{_libdir}/*.so.*
57 %{_datadir}/gupnp-av/*.xsd
58
59 %files devel
60 %defattr(-,root,root,-)
61 %{_includedir}/gupnp-av-1.0/libgupnp-av
62 %{_libdir}/*.so
63 %{_libdir}/pkgconfig/gupnp-av-1.0.pc
64 %{_libdir}/girepository-1.0/GUPnPAV-1.0.typelib
65 %{_datadir}/gir-1.0/GUPnPAV-1.0.gir
66 %{_datadir}/vala/vapi/gupnp-av-1.0.deps
67 %{_datadir}/vala/vapi/gupnp-av-1.0.vapi
68