Fix for UBSan build
[platform/upstream/doxygen.git] / packages / rpm / doxygen.spec
1 %define version 1.8.2
2 %define revision 1
3 %define mmn 1
4 %define name doxygen
5
6 # optionally pass --with-doxywizard to rpmbuild
7
8 %define contentdir /var/www
9 %define suexec_caller doxygen
10 %define buildroot /var/tmp/%{name}-%{version}-%{revision}root
11
12 Summary: A documentation system for C/C++.
13 Name: doxygen
14 Version: %{version}
15 Release: %{revision}
16 URL: http://www.stack.nl/~dimitri/doxygen/index.html
17 Vendor: Dimitri van Heesch
18 License: GNU General Public License
19 Group: Development/Tools
20 Source: %{name}-%{version}.src.tar.gz
21 BuildRoot: %{buildroot}
22 BuildRequires: libstdc++-devel >= 2.96, /usr/bin/perl, /usr/bin/latex, /usr/bin/dvips, /usr/bin/gs
23 Requires: /sbin/chkconfig, /bin/mktemp, /bin/rm, /bin/mv, libstdc++ >= 2.96
24 Provides: doxygen = %{mmn}
25
26 %description
27 Doxygen can generate an online class browser (in HTML) and/or a
28 reference manual (in LaTeX) from a set of documented source files. The
29 documentation is extracted directly from the sources. Doxygen can
30 also be configured to extract the code structure from undocumented
31 source files.
32
33 %if %{?_with_doxywizard:1}%{!?_with_doxywizard:0}
34 %package doxywizard
35 Group: Development/Libraries
36 Summary: GUI Interface for doxygen.
37 Requires: doxygen = %{mmn}
38 Requires: qt >= 3.3
39 Provides: doxywizard = %{mmn}
40 # Obsoletes:
41
42 %description doxywizard
43 Doxygen can generate an online class browser (in HTML) and/or a
44 reference manual (in LaTeX) from a set of documented source files. The
45 documentation is extracted directly from the sources. Doxygen can
46 also be configured to extract the code structure from undocumented
47 source files.
48
49 This is the GUI interface for doxygen.  It requires qt and X11 to
50 install.
51 %endif
52
53 %prep
54 %setup -q -n %{name}-%{version}
55 ./configure %{?_with_doxywizard} --prefix $RPM_BUILD_ROOT/usr
56
57 %build
58 make %{?_smp_mflags}
59 make %{?_smp_mflags} pdf
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 make install
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(-,root,root)
70
71 %doc README LICENSE LANGUAGE.HOWTO examples ./latex/*.pdf
72 %doc /usr/man/man1/doxygen.1.gz
73
74 %{_bindir}/doxygen
75
76 %if %{?_with_doxywizard:1}%{!?_with_doxywizard:0}
77 %files doxywizard
78 %defattr(-,root,root)
79 %{_bindir}/doxywizard
80 %doc /usr/man/man1/doxywizard.1.gz
81 %endif
82
83 %changelog
84 * Fri Apr 18 2008 Kenneth Porter <shiva+doxygenspec@sewingwitch.com> 1.5.5-1
85 - consolidate with and without doxywizard spec files with rpm macro
86 - add gs BuildPrereq
87
88 * Sun Nov 18 2007 Kevin McBride <kevin@planetsaphire.com> 1.5.4
89 - consolidated manual package in lieu of --excludedocs flag for rpm --install
90
91 * Mon Oct 10 2005 Kevin McBride <kevin@planetsaphire.com> 1.4.5
92 - fixed versioning bugs.
93
94 * Tue Oct 4 2005 Kevin McBride <kevin@planetsaphire.com> 1.4.5
95 - added obsoletes and proides sections.
96
97 * Sun Sep 20 2005 Kevin McBride <kevin@planetsaphire.com> 1.4.4
98 - modified rpm spec file for Fedora Core acceptance criteria.
99
100 * Sun Aug 7 2005 Kevin McBride <kevin@planetsaphire.com> 1.4.4
101 - created initial rpm spec file for doxygen-1.4.4
102