626e9f6f4c5897f13fcc4b9f41b7b056b32503a4
[platform/upstream/mtools.git] / mtools.spec
1 Name:           mtools
2 Summary:        mtools, read/write/list/format DOS disks under Unix
3 Version:        4.0.17
4 Release:        1
5 License:        GPLv3+
6 Group:          Utilities/System
7 URL:            http://www.gnu.org/software/mtools/
8 Source:         ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
9 Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10
11
12 %description
13 Mtools is a collection of utilities to access MS-DOS disks from GNU
14 and Unix without mounting them. It supports long file names, OS/2 Xdf
15 disks, ZIP/JAZ disks and 2m disks (store up to 1992k on a high density
16 3 1/2 disk).
17
18
19 %prep
20 %setup -q
21
22 ./configure \
23     --prefix=%{buildroot}%{_prefix} \
24     --sysconfdir=/etc \
25     --infodir=%{buildroot}%{_infodir} \
26     --mandir=%{buildroot}%{_mandir} \
27     --enable-floppyd \
28
29 %build
30 make
31
32 %clean
33 echo rm -rf $RPM_BUILD_ROOT
34 [ X%{buildroot} != X ] && [ X%{buildroot} != X/ ] && rm -fr %{buildroot}
35
36 %install
37 make install
38 make install-info
39 strip %{buildroot}%{_bindir}/mtools %{buildroot}%{_bindir}/mkmanifest %{buildroot}%{_bindir}/floppyd
40 rm %{buildroot}%{_infodir}/dir
41
42 %files
43 %defattr(-,root,root)
44 %{_infodir}/mtools.info*
45 %{_mandir}/man1/floppyd.1*
46 %{_mandir}/man1/floppyd_installtest.1.gz
47 %{_mandir}/man1/mattrib.1*
48 %{_mandir}/man1/mbadblocks.1*
49 %{_mandir}/man1/mcat.1*
50 %{_mandir}/man1/mcd.1*
51 %{_mandir}/man1/mclasserase.1*
52 %{_mandir}/man1/mcopy.1*
53 %{_mandir}/man1/mdel.1*
54 %{_mandir}/man1/mdeltree.1*
55 %{_mandir}/man1/mdir.1*
56 %{_mandir}/man1/mdu.1*
57 %{_mandir}/man1/mformat.1*
58 %{_mandir}/man1/minfo.1*
59 %{_mandir}/man1/mkmanifest.1*
60 %{_mandir}/man1/mlabel.1*
61 %{_mandir}/man1/mmd.1*
62 %{_mandir}/man1/mmount.1*
63 %{_mandir}/man1/mmove.1*
64 %{_mandir}/man1/mpartition.1*
65 %{_mandir}/man1/mrd.1*
66 %{_mandir}/man1/mren.1*
67 %{_mandir}/man1/mshortname.1*
68 %{_mandir}/man1/mshowfat.1*
69 %{_mandir}/man1/mtools.1*
70 %{_mandir}/man5/mtools.5*
71 %{_mandir}/man1/mtoolstest.1*
72 %{_mandir}/man1/mtype.1*
73 %{_mandir}/man1/mzip.1*
74 %{_bindir}/amuFormat.sh
75 %{_bindir}/mattrib
76 %{_bindir}/mbadblocks
77 %{_bindir}/mcat
78 %{_bindir}/mcd
79 %{_bindir}/mclasserase
80 %{_bindir}/mcopy
81 %{_bindir}/mdel
82 %{_bindir}/mdeltree
83 %{_bindir}/mdir
84 %{_bindir}/mdu
85 %{_bindir}/mformat
86 %{_bindir}/minfo
87 %{_bindir}/mkmanifest
88 %{_bindir}/mlabel
89 %{_bindir}/mmd
90 %{_bindir}/mmount
91 %{_bindir}/mmove
92 %{_bindir}/mpartition
93 %{_bindir}/mrd
94 %{_bindir}/mren
95 %{_bindir}/mshortname
96 %{_bindir}/mshowfat
97 %{_bindir}/mtools
98 %{_bindir}/mtoolstest
99 %{_bindir}/mtype
100 %{_bindir}/mzip
101 %{_bindir}/floppyd
102 %{_bindir}/floppyd_installtest
103 %{_bindir}/mcheck
104 %{_bindir}/mcomp
105 %{_bindir}/mxtar
106 %{_bindir}/tgz
107 %{_bindir}/uz
108 %{_bindir}/lz
109 %doc NEWS
110
111 %pre
112 groupadd floppy 2>/dev/null || echo -n ""
113
114 %post
115 if [ -f %{_bindir}/install-info ] ; then
116         if [ -f %{_infodir}/dir ] ; then
117                 %{_bindir}/install-info %{_infodir}/mtools.info %{_infodir}/dir
118         fi
119         if [ -f %{_infodir}/dir.info ] ; then
120                 %{_bindir}/install-info %{_infodir}/mtools.info %{_infodir}/dir.info
121         fi
122 fi
123
124
125 %preun
126 install-info --delete %{_infodir}/mtools.info %{_infodir}/dir.info
127 if [ -f %{_bindir}/install-info ] ; then
128         if [ -f %{_infodir}/dir ] ; then
129                 %{_bindir}/install-info --delete %{_infodir}/mtools.info %{_infodir}/dir
130         fi
131         if [ -f %{_infodir}/dir.info ] ; then
132                 %{_bindir}/install-info --delete %{_infodir}/mtools.info %{_infodir}/dir.info
133         fi
134 fi
135
136 %changelog
137 * Wed Jun 29 2011 Alain Knaff <alain@knaff.lu>
138 - mbadblocks now takes a list of bad blocks (either as sectors
139   or as clusters)
140 - mbadblocks now is able to do write scanning for bad blocks
141 - mshowfat can show cluster of specific offset
142 - Enable mtools to deal with very small sector sizes...
143 - Fixed encoding of all-lowercase names (no need to mangle
144   these)
145 - Consider every directory entry after an ENDMARK (0x00) to be deleted
146 - After writing a new entry at end of a directory, be sure to also add
147   an ENDMARK (0x00)
148 - Deal with possibility of a NULL pointer being returned by
149   localtime during timestamp conversion
150 * Sat Apr 16 2011 Alain Knaff <alain@knaff.lu>
151 - configure.in fixes
152 - fixed formatting of fat_size_calculation.tex document
153 - compatibility with current autoconfig versions
154 - Make it clear that label is limited to 11 characters
155 - Fixed typo in initialization of FAT32 info sector
156 * Sun Oct 17 2010 Alain Knaff <alain@knaff.lu>
157 - Added missing -i option to mshortname
158 * Sun Oct 17 2010 Alain Knaff <alain@knaff.lu>
159 - Released v4_0_14:
160 - New mshortname command
161 - Fix floppyd for disks bigger than 2 Gig
162 - Remove obsolete -z flag
163 - Remove now unsupported AC_USE_SYSTEM_EXTENSIONS
164 - Fixed output formatting of mdir if MTOOLS_DOTTED_DIR is set
165 - Mformat now correctly writes backup boot sector
166 - Fixed signedness of serial number in mlabel
167 - Fixed buffer size problem in mlabel
168 - Make mlabel write backup boot sector if FAT32
169 - Catch situation where both clear and new label are given to mlabel
170 - Quote filename parameters to scripts
171 - Mformat: Close file descriptor for boot sector
172 - Added lzip support to scripts/uz
173 - Added Tot_sectors option to mformat
174 - Fixed hidden sector handling in mformat
175 - Minfo generates mformat command lines containing new -T option
176 - Mlabel prints error if label too long
177 * Sun Feb 28 2010 Alain Knaff <alain@knaff.lu>
178 - Merged Debian patches
179 * Tue Nov 03 2009 Alain Knaff <alain@knaff.lu>
180 - Mingw compatibility fixes