Imported Upstream version 1.10.1
[platform/upstream/ninja.git] / misc / packaging / ninja.spec
1 Summary: Ninja is a small build system with a focus on speed.
2 Name: ninja
3 Version: %{ver}
4 Release: %{rel}%{?dist}
5 Group: Development/Tools
6 License: Apache 2.0
7 URL: https://github.com/ninja-build/ninja
8 Source0: %{name}-%{version}-%{rel}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{rel}
10
11 BuildRequires: asciidoc
12
13 %description
14 Ninja is yet another build system. It takes as input the interdependencies of files (typically source code and output executables) and
15 orchestrates building them, quickly.
16
17 Ninja joins a sea of other build systems. Its distinguishing goal is to be fast. It is born from my work on the Chromium browser project,
18 which has over 30,000 source files and whose other build systems (including one built from custom non-recursive Makefiles) can take ten
19 seconds to start building after changing one file. Ninja is under a second.
20
21 %prep
22 %setup -q -n %{name}-%{version}-%{rel}
23
24 %build
25 echo Building..
26 ./configure.py --bootstrap
27 ./ninja manual
28
29 %install
30 mkdir -p %{buildroot}%{_bindir} %{buildroot}%{_docdir}
31 cp -p ninja %{buildroot}%{_bindir}/
32
33 %files
34 %defattr(-, root, root)
35 %doc COPYING README.md doc/manual.html
36 %{_bindir}/*
37
38 %clean
39 rm -rf %{buildroot}
40
41 #The changelog is built automatically from Git history
42 %changelog