filesystem layout: configure via base-files instead of config-image
[scm/bb/meta-tizen.git] / meta-tizen-common-base / recipes-image / images / tizen-core-image-minimal.bb
1 SUMMARY = "A very basic Wayland image with a terminal"
2
3 IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs"
4
5 LICENSE = "MIT"
6
7 inherit core-image distro_features_check
8
9 REQUIRED_DISTRO_FEATURES = "wayland pam"
10
11 # Because of our symlink hack for /lib /sbin /bin,
12 # this package must be installed first and not just
13 # randomly based of some dependency.
14 IMAGE_INSTALL_prepend = "base-files "
15
16 CORE_IMAGE_BASE_INSTALL += "weston weston-init clutter-1.0-examples"
17
18 DESCRIPTION = "A weston image with Tizen common."
19
20 DEPENDS += " tar-replacement-native "
21
22 CORE_IMAGE_BASE_INSTALL += "connman"
23 CORE_IMAGE_BASE_INSTALL += "${WESTONSTARTUP}"
24
25 # Profile specific configuration - default is Tizen common
26 CORE_IMAGE_BASE_INSTALL += "${IMAGECONFIG}"
27
28 CORE_IMAGE_BASE_INSTALL += "tlm"
29 CORE_IMAGE_BASE_INSTALL += "${TLMCONFIG}"
30
31
32 CORE_IMAGE_BASE_INSTALL += "mesa-megadriver"
33 CORE_IMAGE_BASE_INSTALL += "libegl-gallium"
34 CORE_IMAGE_BASE_INSTALL += "libegl-mesa"
35 CORE_IMAGE_BASE_INSTALL += "libgbm"
36 CORE_IMAGE_BASE_INSTALL += "libgbm-gallium"
37 CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-swrast"
38 CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-vmwgfx"
39 CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-i915"
40 CORE_IMAGE_BASE_INSTALL += "libgles1-mesa"
41 CORE_IMAGE_BASE_INSTALL += "libgles2-mesa"
42 CORE_IMAGE_BASE_INSTALL += "gum-utils"
43 CORE_IMAGE_BASE_INSTALL += "meta-common"
44 CORE_IMAGE_BASE_INSTALL += "pam"
45 CORE_IMAGE_BASE_INSTALL += "user-session-units"
46 CORE_IMAGE_BASE_INSTALL += "default-ac-domains"
47 CORE_IMAGE_BASE_INSTALL += "rpm-security-plugin"
48 CORE_IMAGE_BASE_INSTALL += "kernel-modules"
49 CORE_IMAGE_BASE_INSTALL += "less"
50 CORE_IMAGE_BASE_INSTALL += "bash"
51 CORE_IMAGE_BASE_INSTALL += "psmisc"
52 CORE_IMAGE_BASE_INSTALL += "coreutils"
53 CORE_IMAGE_BASE_INSTALL += "procps"
54
55 # Fonts
56 CORE_IMAGE_EXTRA_INSTALL += "packagegroup-tizen-fonts-ttf"
57 CORE_IMAGE_EXTRA_INSTALL += "packagegroup-tizen-fonts-pango"
58
59 export SYSROOT = "${IMAGE_ROOTFS}"