update weston and weston-common
[scm/bb/meta-tizen.git] / meta-tizen-adaptation-oe-core / recipes-kernel / linux / linux-yocto_3.14.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3 SRC_URI += "file://defconfig"
4 SRC_URI += "file://0001-Smack-Cgroup-filesystem-access.patch"
5 SRC_URI += "file://0002-SMACK-Fix-handling-value-NULL-in-post-setxattr.patch"
6 # TMP fix for error: "implicit declaration of function 'sk_run_filter'"
7 SRC_URI += "file://0001-net-ptp-use-sk_unattached_filter_create-for-BPF.patch"
8 SRC_URI += "file://0001-net-ptp-do-not-reimplement-PTP-BPF-classifier.patch"
9 SRC_URI += "file://0001-net-ptp-move-PTP-classifier-in-its-own-file.patch"
10
11 # Setting the KCONFIG_MODE variable prevents it to being set to
12 # "--allnoconfig" which disable all kernel options.
13 KCONFIG_MODE = "--reconfig"
14
15 # Per MACHINE defconfig files.
16 # Since only two different defconfig files exist, one for i586 arch and
17 # the other one for x86_64 arch, there may be a better way to select the
18 # right defconfig file so we don't have to add all the MACHINE.
19 # arm defconfig
20 COMPATIBLE_MACHINE_qemuarm = "(.*)"
21 # i586 defconfig
22 COMPATIBLE_MACHINE_valleyisland-32 = "(.*)"
23 COMPATIBLE_MACHINE_genericx86 = "(.*)"
24 COMPATIBLE_MACHINE_qemux86 = "(.*)"
25 # x86_64 defconfig
26 COMPATIBLE_MACHINE_valleyisland-64 = "(.*)"
27 COMPATIBLE_MACHINE_romley-ivb = "(.*)"
28 COMPATIBLE_MACHINE_haswell-wc = "(.*)"
29 COMPATIBLE_MACHINE_genericx86-64 = "(.*)"
30 COMPATIBLE_MACHINE_qemux86-64 = "(.*)"