gcc 3.x was miscompiling this function at -O2 and above. Rearrange things
[platform/upstream/libvorbis.git] / libvorbis.spec
1 Name:           libvorbis
2 Version:        1.0
3 Release:        1
4 Summary:        The Vorbis General Audio Compression Codec
5
6 Group:          System Environment/Libraries
7 License:        BSD
8 URL:            http://www.xiph.org/
9 Vendor:         Xiph.org Foundation <team@xiph.org>
10 Source:         http://www.xiph.org/pub/ogg/vorbis/download/%{name}-%{version}.tar.gz
11 Prefix:         %{_prefix}
12 BuildRoot:      %{_tmppath}/%{name}-root
13
14 # We're forced to use an epoch since both Red Hat and Ximian use it in their
15 # rc packages
16 Epoch:          2
17 # Dirty trick to tell rpm that this package actually provides what the
18 # last rc and beta was offering
19 Provides:       %{name} = %{epoch}:1.0rc3-%{release}
20 Provides:       %{name} = %{epoch}:1.0beta4-%{release}
21
22 Requires:       libogg >= 1.0
23 BuildRequires:  libogg-devel >= 1.0
24
25 %description
26 Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
27 general-purpose compressed audio format for audio and music at fixed 
28 and variable bitrates from 16 to 128 kbps/channel.
29
30 %package devel
31 Summary:        Vorbis Library Development
32 Group:          Development/Libraries
33 Requires:       libogg-devel >= 1.0
34 Requires:       libvorbis = %{version}
35 # Dirty trick to tell rpm that this package actually provides what the
36 # last rc and beta was offering
37 Provides:       %{name}-devel = %{epoch}:1.0rc3-%{release}
38 Provides:       %{name}-devel = %{epoch}:1.0beta4-%{release}
39
40 %description devel
41 The libvorbis-devel package contains the header files, static libraries 
42 and documentation needed to develop applications with libvorbis.
43
44 %prep
45 %setup -q -n %{name}-%{version}
46
47 %build
48 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} --enable-static
49 make
50
51 %install
52 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
53
54 make DESTDIR=$RPM_BUILD_ROOT install
55
56 %clean 
57 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
58
59 %post
60 /sbin/ldconfig
61
62 %postun
63 /sbin/ldconfig
64
65 %files
66 %defattr(-,root,root)
67 %doc COPYING
68 %doc AUTHORS
69 %doc README
70 %{_libdir}/libvorbis.so.*
71 %{_libdir}/libvorbisfile.so.*
72 %{_libdir}/libvorbisenc.so.*
73
74 %files devel
75 %doc doc/*.html
76 %doc doc/*.png
77 %doc doc/*.txt
78 %doc doc/vorbisfile
79 %doc doc/vorbisenc
80 %{_datadir}/aclocal/vorbis.m4
81 %{_includedir}/vorbis/codec.h
82 %{_includedir}/vorbis/vorbisfile.h
83 %{_includedir}/vorbis/vorbisenc.h
84 %{_libdir}/libvorbis.a
85 %{_libdir}/libvorbis.so
86 %{_libdir}/libvorbisfile.a
87 %{_libdir}/libvorbisfile.so
88 %{_libdir}/libvorbisenc.a
89 %{_libdir}/libvorbisenc.so
90
91 %changelog
92 * Sun Jul 14 2002 Thomas Vander Stichele <thomas@apestaart.org>
93 - Added BuildRequires:
94 - updated for 1.0 release
95
96 * Sat May 25 2002 Michael Smith <msmith@icecast.org>
97 - Fixed requires, copyright string.
98 * Sun Dec 31 2001 Jack Moffitt <jack@xiph.org>
99 - Updated for rc3 release.
100
101 * Sun Oct 07 2001 Jack Moffitt <jack@xiph.org>
102 - Updated for configurable prefixes
103
104 * Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
105 - initial spec file created