Fix to segfault unpacking a sparse book
[platform/upstream/libvorbis.git] / libvorbis.spec
1 %define name    libvorbis
2 %define version 1.0rc3
3 %define release 1
4
5 Summary:        The Vorbis General Audio Compression Codec
6 Name:           %{name}
7 Version:        %{version}
8 Release:        %{release}
9 Group:          Libraries/Multimedia
10 Copyright:      LGPL
11 URL:            http://www.xiph.org/
12 Vendor:         Xiphophorus <team@xiph.org>
13 Source:         ftp://ftp.xiph.org/pub/ogg/vorbis/%{name}-%{version}.tar.gz
14 BuildRoot:      %{_tmppath}/%{name}-root
15 Requires:       libogg >= 1.0rc3
16 Prefix:         %{_prefix}
17
18 %description
19 Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
20 general-purpose compressed audio format for audio and music at fixed 
21 and variable bitrates from 16 to 128 kbps/channel.
22
23 %package devel
24 Summary:        Vorbis Library Development
25 Group:          Development/Libraries
26 Requires:       libogg-devel >= 1.0rc3
27 Requires:       libvorbis-devel = %{version}
28
29 %description devel
30 The libvorbis-devel package contains the header files and documentation
31 needed to develop applications with libvorbis.
32
33 %prep
34 %setup -q -n %{name}-%{version}
35
36 %build
37 if [ ! -f configure ]; then
38   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{_prefix}
39 else
40   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
41 fi
42 make
43
44 %install
45 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
46 make DESTDIR=$RPM_BUILD_ROOT install
47
48 %files
49 %defattr(-,root,root)
50 %doc COPYING
51 %doc AUTHORS
52 %doc README
53 %{_libdir}/libvorbis.so.*
54 %{_libdir}/libvorbisfile.so.*
55 %{_libdir}/libvorbisenc.so.*
56
57 %files devel
58 %doc doc/*.html
59 %doc doc/*.png
60 %doc doc/*.txt
61 %doc doc/vorbisfile
62 %doc doc/vorbisenc
63 %{_datadir}/aclocal/vorbis.m4
64 %{_includedir}/vorbis/codec.h
65 %{_includedir}/vorbis/vorbisfile.h
66 %{_includedir}/vorbis/vorbisenc.h
67 %{_libdir}/libvorbis.a
68 %{_libdir}/libvorbis.so
69 %{_libdir}/libvorbisfile.a
70 %{_libdir}/libvorbisfile.so
71 %{_libdir}/libvorbisenc.a
72 %{_libdir}/libvorbisenc.so
73
74 %clean 
75 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
76
77 %post
78 /sbin/ldconfig
79
80 %postun
81 /sbin/ldconfig
82
83 %changelog
84 * Sun Dec 31 2001 Jack Moffitt <jack@xiph.org>
85 - Updated for rc3 release.
86
87 * Sun Oct 07 2001 Jack Moffitt <jack@xiph.org>
88 - Updated for configurable prefixes
89
90 * Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
91 - initial spec file created