Refine VA_FOOL, and delete the hard coded clip va_fool_264.h
[platform/upstream/libva.git] / libva.spec
1 #%define moduledir %(pkg-config xorg-server --variable=moduledir)
2
3 Name:           libva
4 Version:        1.0.6
5 Release:        0.0
6 License:        MIT license
7 Source:         %{name}-%{version}.tar.bz2
8 NoSource:       0
9 Group:          Development/Libraries
10 Summary:        Video Acceleration (VA) API for Linux
11 URL:            http://freedesktop.org/wiki/Software/vaapi
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
13
14 Requires: xorg-x11-server-Xorg
15
16 BuildRequires: libtool xorg-x11-server-devel pkgconfig(xv) pkgconfig(xrandr)
17 BuildRequires: libdrm-devel libX11-devel libXext-devel libXdamage-devel libXfixes-devel xorg-x11-proto-dri2proto
18 BuildRequires: xorg-x11-proto-damageproto xorg-x11-proto-kbproto xorg-x11-proto-xproto xorg-x11-proto-xextproto xorg-x11-proto-fixesproto
19
20 %description
21 The libva library implements the Video Acceleration (VA) API for Linux.
22 The library loads a hardware dependendent driver.
23
24 %package devel
25 Summary: Video Acceleration (VA) API for Linux -- development files
26 Group:          Development/Libraries
27 Requires: %{name} = %{version}-%{release}
28 Requires: pkgconfig
29
30 %description devel
31 The libva library implements the Video Acceleration (VA) API for Linux.
32 The library loads a hardware dependendent driver.
33
34 This package provides the development environment for libva.
35
36 %prep
37 %setup -q
38
39 %build
40 unset LD_AS_NEEDED
41 %autogen
42 make
43
44 %install
45 %make_install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(-,root,root,-)
55 %{_libdir}/libva.so.1
56 %{_libdir}/libva.so.%{version}
57 %{_libdir}/libva-tpi.so.1
58 %{_libdir}/libva-tpi.so.%{version}
59 %{_libdir}/libva-x11.so.1
60 %{_libdir}/libva-x11.so.%{version}
61 %{_libdir}/libva-glx.so.1
62 %{_libdir}/libva-glx.so.%{version}
63 %{_bindir}/vainfo
64 %{_bindir}/test_*
65 %{_bindir}/h264encode
66 %{_bindir}/mpeg2vldemo
67 %{_bindir}/putsurface
68
69 %{_libdir}/dri/dummy_drv_video.so
70
71 %{_includedir}/va/va_tpi.h
72 %{_includedir}/va/va_x11.h
73 %{_includedir}/va/va_version.h
74 %{_includedir}/va/va_backend.h
75 %{_includedir}/va/va_dri2.h
76 %{_includedir}/va/va_dummy.h
77 %{_includedir}/va/va_backend_tpi.h
78 %{_includedir}/va/va.h
79 %{_includedir}/va/va_dricommon.h
80 %{_includedir}/va/va_dri.h
81
82 %files devel
83 %defattr(-,root,root,-)
84 %dir %{_includedir}/va
85 %{_includedir}/va/*
86 %{_libdir}/libva.so
87 %{_libdir}/libva-tpi.so
88 %{_libdir}/libva-x11.so
89 %{_libdir}/pkgconfig/libva.pc
90 %{_libdir}/pkgconfig/libva-tpi.pc
91 %{_libdir}/pkgconfig/libva-x11.pc
92 %{_libdir}/pkgconfig/libva-glx.pc
93
94 %changelog
95 * Wed Dec 23 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 1.0.1
96 - Updated libva source to IMG Alpha7
97 * Fri Dec 18 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
98 - Updated libva source to IMG Alpha6
99 * Tue Nov 24 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
100 - Updated libva source
101 * Mon Nov  9 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
102 - Update to version 0.31.0
103 * Tue Jul  7 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.30.4
104 - Update to version 0.30.4
105 * Wed Jun 24 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.30.20090618
106 - Update to version 0.30.20090618_Alpha2.3
107 * Thu Jun 11 2009 Priya Vijayan <priya.vijayan@intel.com> 0.30.20090608
108 - Update to version 0.30.20090608
109 * Tue Jun  2 2009 Anas Nashif <anas.nashif@intel.com> - 0.30~20090514
110 - unset LD_AS_NEEDED
111 * Fri May 15 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090514
112 - Update to latest snapshot 20090514
113 * Wed Apr 29 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090428
114 - Update to 20090428 snpashot
115 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
116 - Update libva.pc with new includedir
117 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
118 - Update to latest snapshot 20090423
119 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
120 - Update to latest snapshot: 20090423
121 * Mon Mar 23 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090323
122 - Update to 0.30~20090323
123 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
124 - Fixing vainfo.c
125 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
126 - fixing va_backend.h
127 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
128 - Updating source
129 * Tue Jan  6 2009 Priya Vijayan <priya.vijayan@intel.com> 0.30
130 - Update to 0.28-working combination with X Server
131 * Fri Dec 19 2008 Priya Vijayan <priya.vijayan@intel.com> 0.30.0
132 - Added definition of FOURCC IYUV
133   * Dec 16 2008 Priya Vijayan <priya.vijayan@intel.com>
134 - Initial Import to MRST
135 * Mon Oct 13 2008 shengquan.yuan@intel.com
136 - packaged mrst-video-decode-src version 0.0.1 using the buildservice spec file wizard