1 #%define moduledir %(pkg-config xorg-server --variable=moduledir)
2 %define libversion 1.0.11
8 Source: %{name}-%{version}.tar.bz2
10 Group: Development/Libraries
11 Summary: Video Acceleration (VA) API for Linux
12 URL: http://freedesktop.org/wiki/Software/vaapi
13 BuildRoot: %{_tmppath}/%{name}-%{version}-build
15 Requires: xorg-x11-server-Xorg
17 Requires: /sbin/ldconfig
18 BuildRequires: pkgconfig(xv)
19 BuildRequires: pkgconfig(xrandr)
20 BuildRequires: pkgconfig(xorg-server)
21 BuildRequires: pkgconfig(libdrm)
22 BuildRequires: pkgconfig(x11)
23 BuildRequires: pkgconfig(xext)
24 BuildRequires: pkgconfig(xdamage)
25 BuildRequires: pkgconfig(xfixes)
26 BuildRequires: pkgconfig(dri2proto)
27 BuildRequires: pkgconfig(damageproto)
28 BuildRequires: pkgconfig(kbproto)
29 BuildRequires: pkgconfig(xextproto)
30 BuildRequires: pkgconfig(fixesproto)
31 BuildRequires: pkgconfig(xproto)
32 BuildRequires: pkgconfig(gl)
33 BuildRequires: libtool
40 The libva library implements the Video Acceleration (VA) API for Linux.
41 The library loads a hardware dependendent driver.
44 Summary: Video Acceleration (VA) API for Linux -- development files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
50 The libva library implements the Video Acceleration (VA) API for Linux.
51 The library loads a hardware dependendent driver.
53 This package provides the development environment for libva.
67 rm -rf $RPM_BUILD_ROOT
69 %post -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
73 %defattr(-,root,root,-)
75 %{_libdir}/libva.so.%{libversion}
76 %{_libdir}/libva-tpi.so.1
77 %{_libdir}/libva-tpi.so.%{libversion}
78 %{_libdir}/libva-x11.so.1
79 %{_libdir}/libva-x11.so.%{libversion}
80 %{_libdir}/libva-glx.so.1
81 %{_libdir}/libva-glx.so.%{libversion}
82 %{_libdir}/libva-egl.so.1
83 %{_libdir}/libva-egl.so.%{libversion}
87 %{_bindir}/mpeg2vldemo
90 %{_libdir}/dri/dummy_drv_video.so
93 %defattr(-,root,root,-)
94 %dir %{_includedir}/va
97 %{_libdir}/libva-tpi.so
98 %{_libdir}/libva-x11.so
99 %{_libdir}/libva-glx.so
100 %{_libdir}/libva-egl.so
101 %{_libdir}/pkgconfig/libva.pc
102 %{_libdir}/pkgconfig/libva-tpi.pc
103 %{_libdir}/pkgconfig/libva-x11.pc
104 %{_libdir}/pkgconfig/libva-glx.pc
105 %{_libdir}/pkgconfig/libva-egl.pc
108 * Tue Jan 25 2011 Austin Yuan <shengquan.yuan@intel.com> 1.0.1
109 - Updated libva source to 1.0.8
110 * Wed Dec 23 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 1.0.1
111 - Updated libva source to IMG Alpha7
112 * Fri Dec 18 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
113 - Updated libva source to IMG Alpha6
114 * Tue Nov 24 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
115 - Updated libva source
116 * Mon Nov 9 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
117 - Update to version 0.31.0
118 * Tue Jul 7 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.30.4
119 - Update to version 0.30.4
120 * Wed Jun 24 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.30.20090618
121 - Update to version 0.30.20090618_Alpha2.3
122 * Thu Jun 11 2009 Priya Vijayan <priya.vijayan@intel.com> 0.30.20090608
123 - Update to version 0.30.20090608
124 * Tue Jun 2 2009 Anas Nashif <anas.nashif@intel.com> - 0.30~20090514
126 * Fri May 15 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090514
127 - Update to latest snapshot 20090514
128 * Wed Apr 29 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090428
129 - Update to 20090428 snpashot
130 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
131 - Update libva.pc with new includedir
132 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
133 - Update to latest snapshot 20090423
134 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
135 - Update to latest snapshot: 20090423
136 * Mon Mar 23 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090323
137 - Update to 0.30~20090323
138 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
140 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
141 - fixing va_backend.h
142 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
144 * Tue Jan 6 2009 Priya Vijayan <priya.vijayan@intel.com> 0.30
145 - Update to 0.28-working combination with X Server
146 * Fri Dec 19 2008 Priya Vijayan <priya.vijayan@intel.com> 0.30.0
147 - Added definition of FOURCC IYUV
148 * Dec 16 2008 Priya Vijayan <priya.vijayan@intel.com>
149 - Initial Import to MRST
150 * Mon Oct 13 2008 shengquan.yuan@intel.com
151 - packaged mrst-video-decode-src version 0.0.1 using the buildservice spec file wizard