1 #%define moduledir %(pkg-config xorg-server --variable=moduledir)
2 %define libversion 1.0.10
8 Source: %{name}-%{version}.tar.bz2
10 Group: Development/Libraries
11 Summary: Video Acceleration (VA) API for Linux
12 URL: http://freedesktop.org/wiki/Software/vaapi
13 BuildRoot: %{_tmppath}/%{name}-%{version}-build
15 Requires: xorg-x11-server-Xorg
17 Requires: /sbin/ldconfig
18 BuildRequires: pkgconfig(xv)
19 BuildRequires: pkgconfig(xrandr)
20 BuildRequires: pkgconfig(xorg-server)
21 BuildRequires: pkgconfig(libdrm)
22 BuildRequires: pkgconfig(x11)
23 BuildRequires: pkgconfig(xext)
24 BuildRequires: pkgconfig(xdamage)
25 BuildRequires: pkgconfig(xfixes)
26 BuildRequires: pkgconfig(dri2proto)
27 BuildRequires: pkgconfig(damageproto)
28 BuildRequires: pkgconfig(kbproto)
29 BuildRequires: pkgconfig(xextproto)
30 BuildRequires: pkgconfig(fixesproto)
31 BuildRequires: pkgconfig(xproto)
32 BuildRequires: pkgconfig(gl)
33 BuildRequires: libtool
40 The libva library implements the Video Acceleration (VA) API for Linux.
41 The library loads a hardware dependendent driver.
44 Summary: Video Acceleration (VA) API for Linux -- development files
45 Group: Development/Libraries
46 Requires: %{name} = %{version}-%{release}
50 The libva library implements the Video Acceleration (VA) API for Linux.
51 The library loads a hardware dependendent driver.
53 This package provides the development environment for libva.
67 rm -rf $RPM_BUILD_ROOT
69 %post -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
73 %defattr(-,root,root,-)
75 %{_libdir}/libva.so.%{libversion}
76 %{_libdir}/libva-tpi.so.1
77 %{_libdir}/libva-tpi.so.%{libversion}
78 %{_libdir}/libva-x11.so.1
79 %{_libdir}/libva-x11.so.%{libversion}
80 %{_libdir}/libva-glx.so.1
81 %{_libdir}/libva-glx.so.%{libversion}
85 %{_bindir}/mpeg2vldemo
88 %{_libdir}/dri/dummy_drv_video.so
91 %defattr(-,root,root,-)
92 %dir %{_includedir}/va
95 %{_libdir}/libva-tpi.so
96 %{_libdir}/libva-x11.so
97 %{_libdir}/libva-glx.so
98 %{_libdir}/pkgconfig/libva.pc
99 %{_libdir}/pkgconfig/libva-tpi.pc
100 %{_libdir}/pkgconfig/libva-x11.pc
101 %{_libdir}/pkgconfig/libva-glx.pc
104 * Tue Jan 25 2011 Austin Yuan <shengquan.yuan@intel.com> 1.0.1
105 - Updated libva source to 1.0.8
106 * Wed Dec 23 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 1.0.1
107 - Updated libva source to IMG Alpha7
108 * Fri Dec 18 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
109 - Updated libva source to IMG Alpha6
110 * Tue Nov 24 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
111 - Updated libva source
112 * Mon Nov 9 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.31.0
113 - Update to version 0.31.0
114 * Tue Jul 7 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.30.4
115 - Update to version 0.30.4
116 * Wed Jun 24 2009 Prajwal Mohan <prajwal.karur.mohan@intel.com> 0.30.20090618
117 - Update to version 0.30.20090618_Alpha2.3
118 * Thu Jun 11 2009 Priya Vijayan <priya.vijayan@intel.com> 0.30.20090608
119 - Update to version 0.30.20090608
120 * Tue Jun 2 2009 Anas Nashif <anas.nashif@intel.com> - 0.30~20090514
122 * Fri May 15 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090514
123 - Update to latest snapshot 20090514
124 * Wed Apr 29 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090428
125 - Update to 20090428 snpashot
126 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
127 - Update libva.pc with new includedir
128 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
129 - Update to latest snapshot 20090423
130 * Sun Apr 26 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090423
131 - Update to latest snapshot: 20090423
132 * Mon Mar 23 2009 Anas Nashif <anas.nashif@intel.com> 0.30~20090323
133 - Update to 0.30~20090323
134 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
136 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
137 - fixing va_backend.h
138 * Fri Jan 16 2009 Priya Vijayan <priya.vijayan@intel.com> 0.31
140 * Tue Jan 6 2009 Priya Vijayan <priya.vijayan@intel.com> 0.30
141 - Update to 0.28-working combination with X Server
142 * Fri Dec 19 2008 Priya Vijayan <priya.vijayan@intel.com> 0.30.0
143 - Added definition of FOURCC IYUV
144 * Dec 16 2008 Priya Vijayan <priya.vijayan@intel.com>
145 - Initial Import to MRST
146 * Mon Oct 13 2008 shengquan.yuan@intel.com
147 - packaged mrst-video-decode-src version 0.0.1 using the buildservice spec file wizard