"Initial commit to Gerrit"
[profile/ivi/libgsf.git] / libgsf-1.spec
1 %define name libgsf
2 %define version 1.14.21
3 %define release 1
4 %define prefix /usr
5
6 Summary: GNOME Structured File library
7
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Group: System Environment/Libraries
12 License: LGPL
13
14 Source: ftp://ftp.gnome.org/pub/GNOME/unstable/sources/libgsf/%{name}-%{version}.tar.gz
15 Buildroot: /var/tmp/%{name}-%{version}-%{release}-root
16 URL: http://www.gnumeric.org
17
18 Requires: glib2 >= 2.6.0
19 BuildRequires: glib2-devel >= 2.6.0
20
21 %description
22 A library for reading and writing structured files (eg MS OLE and Zip)
23
24 %package devel
25 Summary: Support files necessary to compile applications with libgsf.
26 Group: Development/Libraries
27 Requires: libgsf
28
29 %description devel
30 Libraries, headers, and support files necessary to compile applications using libgsf.
31
32 %prep
33
34 %setup
35
36 %build
37 %ifarch alpha
38   MYARCH_FLAGS="--host=alpha-redhat-linux"
39 %endif
40
41 if [ ! -f configure ]; then
42 CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{prefix}
43 else
44 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix}
45 fi
46
47 if [ "$SMP" != "" ]; then
48   (make "MAKE=make -k -j $SMP"; exit 0)
49   make
50 else
51   make
52 fi
53
54 %install
55 if [ -d $RPM_BUILD_ROOT ]; then rm -r $RPM_BUILD_ROOT; fi
56 mkdir -p $RPM_BUILD_ROOT%{prefix}
57 make prefix=$RPM_BUILD_ROOT%{prefix} install
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS COPYING README
62 %{prefix}/lib/lib*.so*
63
64 %files devel
65 %defattr(644,root,root,755)
66 %{prefix}/lib/*a
67 %{prefix}/lib/pkgconfig/libgsf-*1.pc
68 %{prefix}/include/libgsf-1/*
69 %{prefix}/share/doc/libgsf/html/*
70
71 %clean
72 rm -r $RPM_BUILD_ROOT
73
74 %changelog
75 * Tue May 13 2003 Rui M. Seabra <rms@407.org>
76 - fix spec to reflect current stat of the build
77
78 * Tue Jun 18 2002 Rui M. Seabra <rms@407.org>
79 - set permission correctly
80 - fix common mistake of Copyright flag into License flag.
81
82 * Thu May 23 2002 Jody Goldberg <jody@gnome.org>
83 - Initial version