Add PIE compilation flags
[platform/upstream/keyutils.git] / keyutils.spec
1 %define vermajor 1
2 %define verminor 5.3
3 %define version %{vermajor}.%{verminor}
4 %define libdir /%{_lib}
5 %define usrlibdir %{_prefix}/%{_lib}
6 %define libapivermajor 1
7 %define libapiversion %{libapivermajor}.4
8
9 Summary: Linux Key Management Utilities
10 Name: keyutils
11 Version: %{version}
12 Release: 1%{?dist}
13 License: GPLv2+ and LGPLv2+
14 Group: System Environment/Base
15 ExclusiveOS: Linux
16 Url: http://people.redhat.com/~dhowells/keyutils/
17
18 Source0: http://people.redhat.com/~dhowells/keyutils/keyutils-%{version}.tar.bz2
19
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21 BuildRequires: glibc-kernheaders >= 2.4-9.1.92
22 Requires: keyutils-libs == %{version}-%{release}
23
24 %description
25 Utilities to control the kernel key management facility and to provide
26 a mechanism by which the kernel call back to user space to get a key
27 instantiated.
28
29 %package libs
30 Summary: Key utilities library
31 Group: System Environment/Base
32
33 %description libs
34 This package provides a wrapper library for the key management facility system
35 calls.
36
37 %package libs-devel
38 Summary: Development package for building Linux key management utilities
39 Group: System Environment/Base
40 Requires: keyutils-libs == %{version}-%{release}
41
42 %description libs-devel
43 This package provides headers and libraries for building key utilities.
44
45 %prep
46 %setup -q
47
48 %build
49 make \
50         NO_ARLIB=1 \
51         LIBDIR=%{libdir} \
52         USRLIBDIR=%{usrlibdir} \
53         RELEASE=.%{release} \
54         NO_GLIBC_KEYERR=1 \
55         CFLAGS="-Wall $RPM_OPT_FLAGS -Werror"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 make \
60         NO_ARLIB=1 \
61         DESTDIR=$RPM_BUILD_ROOT \
62         LIBDIR=%{libdir} \
63         USRLIBDIR=%{usrlibdir} \
64         install
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post libs -p /sbin/ldconfig
70 %postun libs -p /sbin/ldconfig
71
72 %files
73 %defattr(-,root,root,-)
74 %doc README LICENCE.GPL
75 /sbin/*
76 /bin/*
77 /usr/share/keyutils
78 %{_mandir}/man1/*
79 %{_mandir}/man5/*
80 %{_mandir}/man8/*
81 %config(noreplace) /etc/*
82
83 %files libs
84 %defattr(-,root,root,-)
85 %doc LICENCE.LGPL
86 %{libdir}/libkeyutils.so.%{libapiversion}
87 %{libdir}/libkeyutils.so.%{libapivermajor}
88
89 %files libs-devel
90 %defattr(-,root,root,-)
91 %{usrlibdir}/libkeyutils.so
92 %{_includedir}/*
93 %{_mandir}/man3/*
94
95 %changelog
96 * Thu Aug 11 2011 David Howells  <dhowells@redhat.com> - 1.5.3-1
97 - Make the keyutils rpm depend on the same keyutils-libs rpm version.
98
99 * Tue Jul 26 2011 David Howells  <dhowells@redhat.com> - 1.5.2-1
100 - Use correct format spec for printing pointer subtraction results.
101
102 * Tue Jul 19 2011 David Howells  <dhowells@redhat.com> - 1.5.1-1
103 - Fix unread variables.
104 - Licence file update.
105
106 * Thu Mar 10 2011 David Howells  <dhowells@redhat.com> - 1.5-1
107 - Disable RPATH setting in Makefile.
108 - Add -I. to build to get this keyutils.h.
109 - Make CFLAGS override on make command line work right.
110 - Make specfile UTF-8.
111 - Support KEYCTL_REJECT.
112 - Support KEYCTL_INSTANTIATE_IOV.
113 - Add AFSDB DNS lookup program from Wang Lei.
114 - Generalise DNS lookup program.
115 - Add recursive scan utility function.
116 - Add bad key reap command to keyctl.
117 - Add multi-unlink variant to keyctl unlink command.
118 - Add multi key purger command to keyctl.
119 - Handle multi-line commands in keyctl command table.
120 - Move the package to version to 1.5.
121
122 * Tue Mar 1 2011 David Howells  <dhowells@redhat.com> - 1.4-4
123 - Make build guess at default libdirs and word size.
124 - Make program build depend on library in Makefile.
125 - Don't include $(DESTDIR) in MAN* macros.
126 - Remove NO_GLIBC_KEYSYS as it is obsolete.
127 - Have Makefile extract version info from specfile and version script.
128 - Provide RPM build rule in Makefile.
129 - Provide distclean rule in Makefile.
130
131 * Fri Dec 17 2010 Diego Elio Pettenò <flameeyes@hosting.flameeyes.eu> - 1.4-3
132 - Fix local linking and RPATH.
133
134 * Thu Jun 10 2010 David Howells  <dhowells@redhat.com> - 1.4-2
135 - Fix prototypes in manual pages (some char* should be void*).
136 - Rename the keyctl_security.3 manpage to keyctl_get_security.3.
137
138 * Fri Mar 19 2010 David Howells  <dhowells@redhat.com> - 1.4-1
139 - Fix the library naming wrt the version.
140 - Move the package to version to 1.4.
141
142 * Fri Mar 19 2010 David Howells  <dhowells@redhat.com> - 1.3-3
143 - Fix spelling mistakes in manpages.
144 - Add an index manpage for all the keyctl functions.
145
146 * Thu Mar 11 2010 David Howells  <dhowells@redhat.com> - 1.3-2
147 - Fix rpmlint warnings.
148
149 * Fri Feb 26 2010 David Howells <dhowells@redhat.com> - 1.3-1
150 - Fix compiler warnings in request-key.
151 - Expose the kernel function to get a key's security context.
152 - Expose the kernel function to set a processes keyring onto its parent.
153 - Move libkeyutils library version to 1.3.
154
155 * Tue Aug 22 2006 David Howells <dhowells@redhat.com> - 1.2-1
156 - Remove syscall manual pages (section 2) to man-pages package [BZ 203582]
157 - Don't write to serial port in debugging script
158
159 * Mon Jun 5 2006 David Howells <dhowells@redhat.com> - 1.1-4
160 - Call ldconfig during (un)installation.
161
162 * Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-3
163 - Don't include the release number in the shared library filename
164 - Don't build static library
165
166 * Fri May 5 2006 David Howells <dhowells@redhat.com> - 1.1-2
167 - More bug fixes from Fedora reviewer.
168
169 * Thu May 4 2006 David Howells <dhowells@redhat.com> - 1.1-1
170 - Fix rpmlint errors
171
172 * Mon Dec 5 2005 David Howells <dhowells@redhat.com> - 1.0-2
173 - Add build dependency on glibc-kernheaders with key management syscall numbers
174
175 * Tue Nov 29 2005 David Howells <dhowells@redhat.com> - 1.0-1
176 - Add data pipe-in facility for keyctl request2
177
178 * Mon Nov 28 2005 David Howells <dhowells@redhat.com> - 1.0-1
179 - Rename library and header file "keyutil" -> "keyutils" for consistency
180 - Fix shared library version naming to same way as glibc.
181 - Add versioning for shared library symbols
182 - Create new keyutils-libs package and install library and main symlink there
183 - Install base library symlink in /usr/lib and place in devel package
184 - Added a keyutils archive library
185 - Shorten displayed key permissions list to just those we actually have
186
187 * Thu Nov 24 2005 David Howells <dhowells@redhat.com> - 0.3-4
188 - Add data pipe-in facilities for keyctl add, update and instantiate
189
190 * Fri Nov 18 2005 David Howells <dhowells@redhat.com> - 0.3-3
191 - Added stdint.h inclusion in keyutils.h
192 - Made request-key.c use request_key() rather than keyctl_search()
193 - Added piping facility to request-key
194
195 * Thu Nov 17 2005 David Howells <dhowells@redhat.com> - 0.3-2
196 - Added timeout keyctl option
197 - request_key auth keys must now be assumed
198 - Fix keyctl argument ordering for debug negate line in request-key.conf
199
200 * Thu Jul 28 2005 David Howells <dhowells@redhat.com> - 0.3-1
201 - Must invoke initialisation from perror() override in libkeyutils
202 - Minor UI changes
203
204 * Wed Jul 20 2005 David Howells <dhowells@redhat.com> - 0.2-2
205 - Bump version to permit building in main repositories.
206
207 * Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.2-1
208 - Don't attempt to define the error codes in the header file.
209 - Pass the release ID through to the makefile to affect the shared library name.
210
211 * Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-3
212 - Build in the perror() override to get the key error strings displayed.
213
214 * Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-2
215 - Need a defattr directive after each files directive.
216
217 * Mon Jul 12 2005 David Howells <dhowells@redhat.com> - 0.1-1
218 - Package creation.