resetting manifest requested domain to floor
[platform/upstream/jasper.git] / jasper.spec
1 # Note that this is NOT a relocatable package
2 %define package_name  jasper
3 %define ver           1.900.1
4 %define prefix        /usr
5 %define datadir       %{prefix}/share
6 %define release       1
7
8 Summary: JasPer
9 Name: %{package_name}
10 Version: %{ver}
11 Release: %{release}
12 Copyright: Modified BSD
13 Group: Development/Libraries
14
15 # FIXME: 
16 Source: http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-1.900.1.tar.gz
17
18 BuildRoot: /var/tmp/%{package_name}-%{version}-root
19 Requires: libjpeg
20 BuildRequires: libjpeg-devel
21 URL: http://www.ece.uvic.ca/~mdadams/jasper/
22
23 %description 
24 JasPer is a collection        
25 of software (i.e., a library and application programs) for the coding 
26 and manipulation of images.  This software can handle image data in a 
27 variety of formats.  One such format supported by JasPer is the JPEG-2000 
28 format defined in ISO/IEC 15444-1:2000.
29
30 %package devel
31 Summary: Include Files and Documentation
32 Group: Development/Libraries
33 Requires: %{package_name} = %{ver}
34
35 %description devel
36 JasPer is a collection        
37 of software (i.e., a library and application programs) for the coding 
38 and manipulation of images.  This software can handle image data in a 
39 variety of formats.  One such format supported by JasPer is the JPEG-2000 
40 code stream format defined in ISO/IEC 15444-1:2000.
41
42 %prep
43 %setup
44
45 ./configure --prefix=/usr --enable-shared
46
47
48 # build
49 %build
50
51 #if [ "$SMP" != "" ]; then
52 #  (make "MAKE=make -k -j $SMP"; exit 0)
53 #  make
54 #else
55   make
56 #fi
57
58
59 # install
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 make prefix=$RPM_BUILD_ROOT%{prefix} install
64
65
66 # clean
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70
71 %post -p /sbin/ldconfig
72
73 %postun -p /sbin/ldconfig
74
75
76 # files main package
77 %files
78 %defattr(-, root, root)
79
80 %doc README LICENSE ChangeLog
81
82 %{prefix}/bin/*
83 %{prefix}/lib/lib*.so.*
84
85 # files devel package
86 %files devel
87 %defattr(-, root, root)
88
89 # no API docs yet :(
90 # %doc doc/html/*
91
92 %{prefix}/include/jasper/*
93 %{prefix}/lib/lib*.so
94 %{prefix}/lib/lib*.a
95 %{prefix}/lib/lib*.la
96
97 %changelog
98
99 * Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
100
101   - spec file created