Ignore grep unit test
[product/upstream/grep.git] / grep.spec
1 %define beta %nil
2 %define rel 1
3 Summary: The GNU versions of grep pattern matching utilities.
4 Name: grep
5 Version: 2.5.2
6 %if "%{beta}" != ""
7 Release: 0.%{beta}.%{rel}ark
8 %else
9 Release: %{rel}ark
10 %endif
11 License: GPL
12 Group: Applications/Text
13 Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}%{beta}.tar.lz
14 Prereq: /sbin/install-info
15 Buildroot: %{_tmppath}/%{name}-%{version}-root
16 Requires: pcre
17 Buildrequires: pcre-devel
18
19 %description
20 The GNU versions of commonly used grep utilities.  Grep searches
21 through textual input for lines which contain a match to a specified
22 pattern and then prints the matching lines.  GNU's grep utilities
23 include grep, egrep and fgrep.
24
25 You should install grep on your system, because it is a very useful
26 utility for searching through text.
27
28 %prep
29 %setup -q -n %{name}-%{version}%{beta}
30
31 %build
32 [ ! -e configure ] && ./autogen.sh
33 %configure --without-included-regex
34 make %?_smp_mflags
35
36 %install
37 rm -rf ${RPM_BUILD_ROOT}
38 #makeinstall LDFLAGS=-s prefix=${RPM_BUILD_ROOT}%{_prefix} exec_prefix=${RPM_BUILD_ROOT}
39 make install DESTDIR="$RPM_BUILD_ROOT"
40 %ifos Linux
41 mkdir -p $RPM_BUILD_ROOT/bin
42 mv $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT/bin
43 rm -rf $RPM_BUILD_ROOT%{_bindir}
44 %endif
45
46 %find_lang %name
47
48 %clean
49 rm -rf ${RPM_BUILD_ROOT}
50
51 %post
52 [ -e %{_infodir}/grep.info.* ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.* || :
53
54 %preun
55 if [ $1 = 0 ]; then
56         [ -e %{_infodir}/grep.info.* ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.*
57 fi
58
59 %files -f %{name}.lang
60 %defattr(-,root,root)
61 %doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog
62
63 %ifos Linux
64 /bin/*
65 %else
66 %{_bindir}/*
67 %endif
68 %{_infodir}/*.info*
69 %{_mandir}/*/*
70
71 %changelog
72 * Sat Nov 25 2006 Bernhard Rosenkraenzer <bero@arklinux.org> 2.5.2-1ark
73 - 2.5.2
74
75 * Mon Nov 29 2004 Bernhard Rosenkraenzer <bero@arklinux.org> 2.5.1a-1ark
76 - 2.5.1a