removed gtranslator for re-checkin
[platform/upstream/gnome-common.git] / gnome-common.spec
1 # Note that this is NOT a relocatable package
2 %define ver      0.99.5
3 %define rel      SNAP
4 %define prefix   /usr
5
6 Summary: Gnome Common
7 Name: gnome-common
8 Version: %ver
9 Release: %rel
10 Copyright: LGPL
11 Group: X11/Libraries
12 Source: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-common/gnome-common-%{ver}.tar.gz
13 BuildRoot: /tmp/gnome-common-root
14 URL: http://www.gnome.org
15 Docdir: %{prefix}/doc
16
17 %description
18 This is required for every GNOME Application that is not in the
19 GNOME CVS Tree.
20
21 %package devel
22 Summary: Required files for GNOME Applications outside CVS
23 Group: X11/libraries
24
25 %description devel
26 This is required for every GNOME Application that is not in the
27 GNOME CVS Tree.
28
29 %prep
30 %setup
31
32 %build
33 # Needed for snapshot releases.
34 if [ ! -f configure ]; then
35   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix
36 else
37   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
38 fi
39
40 if [ "$SMP" != "" ]; then
41   (make "MAKE=make -k -j $SMP"; exit 0)
42   make
43 else
44   make
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 make prefix=$RPM_BUILD_ROOT%{prefix} install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-, root, root)
57
58 %doc AUTHORS COPYING ChangeLog NEWS README
59
60 %files devel
61 %defattr(-, root, root)
62
63 %{prefix}/share/aclocal/gnome/*
64