Took my name out of the spec file. I was being blamed for duff builds :-)
[platform/upstream/glib.git] / glib.spec
1 # Note that this is NOT a relocatable package
2 %define ver      1.1.3
3 %define rel      SNAP
4 %define prefix   /usr
5
6 Summary: Handy library of utility functions
7 Name: glib
8 Version: %ver
9 Release: %rel
10 Copyright: LGPL
11 Group: Libraries
12 Source: ftp://ftp.gimp.org/pub/gtk/v1.0/glib-%{ver}.tar.gz
13 BuildRoot: /tmp/glib-root
14 URL: http://www.gtk.org
15 Docdir: %{prefix}/doc
16
17 %description
18 Handy library of utility functions.  Development libs and headers
19 are in glib-devel.
20
21 %package devel
22 Summary: GIMP Toolkit and GIMP Drawing Kit support library
23 Group: X11/Libraries
24
25 %description devel
26 Static libraries and header files for the support library for the GIMP's X
27 libraries, which are available as public libraries.  GLIB includes generally
28 useful data structures.
29
30
31 %changelog
32
33 * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
34
35 - Split out glib package
36
37 %prep
38 %setup
39
40 %build
41 # Needed for snapshot releases.
42 if [ ! -f configure ]; then
43   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix
44 else
45   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
46 fi
47
48 if [ "$SMP" != "" ]; then
49   (make "MAKE=make -k -j $SMP"; exit 0)
50   make
51 else
52   make
53 fi
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 make prefix=$RPM_BUILD_ROOT%{prefix} install
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post -p /sbin/ldconfig
64
65 %postun -p /sbin/ldconfig
66
67 %files
68 %defattr(-, root, root)
69
70 %doc AUTHORS COPYING ChangeLog NEWS README
71 %{prefix}/lib/libglib-1.1.so.*
72
73 %files devel
74 %defattr(-, root, root)
75
76 %{prefix}/lib/lib*.so
77 %{prefix}/lib/*a
78 %{prefix}/lib/glib
79 %{prefix}/include/*
80 %{prefix}/share/aclocal/*
81 %{prefix}/bin/*