cleaned up the errno mess for GETPWUID. we especially don't want to
[platform/upstream/glib.git] / glib.spec
1 # Note that this is NOT a relocatable package
2 %define ver      1.1.13
3 %define rel      SNAP
4 %define prefix   /usr
5
6 Summary: Handy library of utility functions
7 Name: glib
8 Version: %ver
9 Release: %rel
10 Copyright: LGPL
11 Group: Libraries
12 Source: ftp://ftp.gimp.org/pub/gtk/v1.1/glib-%{ver}.tar.gz
13 BuildRoot: /tmp/glib-root
14 Packager: Christopher Blizzard <blizzard@appliedtheory.com>
15 URL: http://www.gtk.org
16 Docdir: %{prefix}/doc
17
18 %description
19 Handy library of utility functions.  Development libs and headers
20 are in glib-devel.
21
22 %package devel
23 Summary: GIMP Toolkit and GIMP Drawing Kit support library
24 Group: X11/Libraries
25
26 %description devel
27 Static libraries and header files for the support library for the GIMP's X
28 libraries, which are available as public libraries.  GLIB includes generally
29 useful data structures.
30
31
32 %changelog
33
34 * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
35
36 - Split out glib package
37
38 %prep
39 %setup
40
41 %build
42 # Needed for snapshot releases.
43 if [ ! -f configure ]; then
44   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix
45 else
46   CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix
47 fi
48
49 if [ "$SMP" != "" ]; then
50   (make "MAKE=make -k -j $SMP"; exit 0)
51   make
52 else
53   make
54 fi
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 make prefix=$RPM_BUILD_ROOT%{prefix} install
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post -p /sbin/ldconfig
65
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(-, root, root)
70
71 %doc AUTHORS COPYING ChangeLog NEWS README
72 %{prefix}/lib/libglib-1.1.so.*
73 %{prefix}/lib/libgmodule-1.1.so.*
74
75 %files devel
76 %defattr(-, root, root)
77
78 %{prefix}/lib/lib*.so
79 %{prefix}/lib/*a
80 %{prefix}/lib/glib
81 %{prefix}/include/*
82 %{prefix}/share/aclocal/*
83 %{prefix}/bin/*