Tizen 2.1 base
[platform/upstream/epson-inkjet-printer-escpr.git] / epson-inkjet-printer-escpr.spec
1
2 %define pkg     epson-inkjet-printer-escpr
3 %define ver     1.2.2
4 %define rel     1
5
6 %define cupsfilterdir   /usr/lib/cups/filter
7 %define cupsppddir      /usr/share/ppd
8
9 Name: %{pkg}
10 Version: %{ver}
11 Release: %{rel}
12 Source0: %{name}-%{version}.tar.gz
13 License: GPL
14 Vendor: Seiko Epson Corporation
15 URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
16 Packager: Seiko Epson Corporation <linux-printer@epson.jp>
17 BuildRoot: %{_tmppath}/%{name}-%{version}
18 Group: Applications/System
19 Summary: Epson Inkjet Printer Driver (ESC/P-R) for Linux
20
21 %description
22 This software is a filter program used with Common UNIX Printing
23 System (CUPS) from the Linux. This can supply the high quality print
24 with Seiko Epson Color Ink Jet Printers.
25
26 This product supports only EPSON ESC/P-R printers. This package can be
27 used for all EPSON ESC/P-R printers.
28
29 For detail list of supported printer, please refer to below site:
30 http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
31
32 %prep
33 %setup -q
34
35 %build
36 %configure \
37         --with-cupsfilterdir=%{cupsfilterdir} \
38         --with-cupsppddir=%{cupsppddir}
39 make
40
41 %install
42 rm -rf ${RPM_BUILD_ROOT}
43 make install-strip DESTDIR=${RPM_BUILD_ROOT}
44
45 %post
46 /sbin/ldconfig
47
48 %postun
49 /sbin/ldconfig
50
51 %clean
52 make clean
53 rm -rf ${RPM_BUILD_ROOT}
54
55 %files
56 %defattr(-,root,root)
57 %doc AUTHORS COPYING NEWS README README.ja
58 %{cupsfilterdir}/epson-escpr
59 %{cupsfilterdir}/epson-escpr-wrapper
60 %{_libdir}/libescpr.*
61 %{cupsppddir}/*.ppd