Imported Upstream version 0.155
[platform/upstream/elfutils.git] / elfutils.spec
1 # -*- rpm-spec-*-
2 Summary: A collection of utilities and DSOs to handle compiled objects
3 Name: elfutils
4 Version: 0.155
5 Release: 1
6 License: GPLv3+ and (GPLv2+ or LGPLv3+)
7 Group: Development/Tools
8 Source: elfutils-%{version}.tar.bz2
9 Obsoletes: libelf libelf-devel
10 Requires: elfutils-libelf = %{version}-%{release}
11 Requires: glibc >= 2.7
12 Requires: libstdc++
13
14 # ExcludeArch: xxx
15
16 BuildRoot: %{_tmppath}/%{name}-root
17 BuildRequires: gcc >= 4.1.2-33
18 BuildRequires: glibc >= 2.7
19 BuildRequires: bison >= 1.875
20 BuildRequires: flex >= 2.5.4a
21 BuildRequires: bzip2
22 BuildRequires: m4
23 BuildRequires: gettext
24 BuildRequires: zlib-devel
25 BuildRequires: bzip2-devel
26 BuildRequires: xz-devel
27 BuildRequires: gcc-c++
28
29 %define _gnu %{nil}
30 %define _programprefix eu-
31
32 %description
33 Elfutils is a collection of utilities, including ld (a linker),
34 nm (for listing symbols from object files), size (for listing the
35 section sizes of an object or archive file), strip (for discarding
36 symbols), readelf (to see the raw ELF file structures), and elflint
37 (to check for well-formed ELF files).  Also included are numerous
38 helper libraries which implement DWARF, ELF, and machine-specific ELF
39 handling.
40
41 %package devel
42 Summary: Development libraries to handle compiled objects.
43 Group: Development/Tools
44 License: GPLv2+ or LGPLv3+
45 Requires: elfutils = %{version}-%{release}
46 Requires: elfutils-libelf-devel = %{version}-%{release}
47
48 %description devel
49 The elfutils-devel package contains the libraries to create
50 applications for handling compiled objects.  libebl provides some
51 higher-level ELF access functionality.  libdw provides access to
52 the DWARF debugging information.  libasm provides a programmable
53 assembler interface.
54
55 %package devel-static
56 Summary: Static archives to handle compiled objects.
57 Group: Development/Tools
58 License: GPLv2+ or LGPLv3+
59 Requires: elfutils-devel = %{version}-%{release}
60
61 %description devel-static
62 The elfutils-devel-static archive contains the static archives
63 with the code the handle compiled objects.
64
65 %package libelf
66 Summary: Library to read and write ELF files.
67 Group: Development/Tools
68 License: GPLv2+ or LGPLv3+
69
70 %description libelf
71 The elfutils-libelf package provides a DSO which allows reading and
72 writing ELF files on a high level.  Third party programs depend on
73 this package to read internals of ELF files.  The programs of the
74 elfutils package use it also to generate new ELF files.
75
76 %package libelf-devel
77 Summary: Development support for libelf
78 Group: Development/Tools
79 License: GPLv2+ or LGPLv3+
80 Requires: elfutils-libelf = %{version}-%{release}
81 Conflicts: libelf-devel
82
83 %description libelf-devel
84 The elfutils-libelf-devel package contains the libraries to create
85 applications for handling compiled objects.  libelf allows you to
86 access the internals of the ELF object file format, so you can see the
87 different sections of an ELF file.
88
89 %package libelf-devel-static
90 Summary: Static archive of libelf
91 Group: Development/Tools
92 License: GPLv2+ or LGPLv3+
93 Requires: elfutils-libelf-devel = %{version}-%{release}
94 Conflicts: libelf-devel
95
96 %description libelf-devel-static
97 The elfutils-libelf-static package contains the static archive
98 for libelf.
99
100 %prep
101 %setup -q
102
103 %build
104 %configure --program-prefix=%{_programprefix}
105 make
106
107 %install
108 rm -rf ${RPM_BUILD_ROOT}
109 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
110
111 %makeinstall
112
113 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
114 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
115
116 # XXX Nuke unpackaged files
117 { cd ${RPM_BUILD_ROOT}
118   rm -f .%{_bindir}/eu-ld
119   rm -f .%{_includedir}/elfutils/libasm.h
120   rm -f .%{_libdir}/libasm.so
121   rm -f .%{_libdir}/libasm.a
122 }
123
124 %check
125 make check
126
127 %clean
128 rm -rf ${RPM_BUILD_ROOT}
129
130 %post -p /sbin/ldconfig
131
132 %postun -p /sbin/ldconfig
133
134 %post libelf -p /sbin/ldconfig
135
136 %postun libelf -p /sbin/ldconfig
137
138 %files
139 %defattr(-,root,root)
140 %doc COPYING COPYING-GPLV2 COPYING-LGPLV3 README TODO CONTRIBUTING
141 %{_bindir}/eu-elflint
142 %{_bindir}/eu-nm
143 %{_bindir}/eu-readelf
144 %{_bindir}/eu-size
145 %{_bindir}/eu-strip
146 %{_bindir}/eu-findtextrel
147 %{_bindir}/eu-addr2line
148 %{_bindir}/eu-elfcmp
149 %{_bindir}/eu-ranlib
150 %{_bindir}/eu-strings
151 %{_bindir}/eu-objdump
152 %{_bindir}/eu-ar
153 %{_bindir}/eu-unstrip
154 %{_bindir}/eu-make-debug-archive
155 #%{_bindir}/eu-ld
156 %{_libdir}/libasm-%{version}.so
157 %{_libdir}/libdw-%{version}.so
158 %{_libdir}/libasm.so.*
159 %{_libdir}/libdw.so.*
160 %dir %{_libdir}/elfutils
161 %{_libdir}/elfutils/lib*.so
162
163 %files devel
164 %defattr(-,root,root)
165 %{_includedir}/dwarf.h
166 %dir %{_includedir}/elfutils
167 %{_includedir}/elfutils/elf-knowledge.h
168 #%{_includedir}/elfutils/libasm.h
169 %{_includedir}/elfutils/libebl.h
170 %{_includedir}/elfutils/libdw.h
171 %{_includedir}/elfutils/libdwfl.h
172 %{_libdir}/libebl.a
173 #%{_libdir}/libasm.so
174 %{_libdir}/libdw.so
175
176 %files devel-static
177 %{_libdir}/libdw.a
178 #%{_libdir}/libasm.a
179
180 %files libelf
181 %defattr(-,root,root)
182 %{_libdir}/libelf-%{version}.so
183 %{_libdir}/libelf.so.*
184 %{_datadir}/locale/*/LC_MESSAGES/elfutils.mo
185
186 %files libelf-devel
187 %defattr(-,root,root)
188 %{_includedir}/libelf.h
189 %{_includedir}/gelf.h
190 %{_includedir}/nlist.h
191 %{_includedir}/elfutils/version.h
192 %{_libdir}/libelf.so
193
194 %files libelf-devel-static
195 %{_libdir}/libelf.a
196
197 %changelog
198 * Fri Aug 24 2012 Mark Wielaard <mjw@redhat.com> 0.155-1
199 - libelf: elf*_xlatetomd now works for cross-endian ELF note data.    
200        elf_getshdr now works consistently on non-mmaped ELF files after 
201           calling elf_cntl(ELF_C_FDREAD).         Implement support for 
202   ar archives with 64-bit symbol table.
203 - libdw: dwarf.h corrected the DW_LANG_ObjC constant name (was 
204   DW_LANG_Objc).        Any existing sources using the old name will 
205   have to be updated.        Add DW_MACRO_GNU .debug_macro type 
206   encodings constants, DW_ATE_UTF        and DW_OP_GNU_parameter_ref to 
207   dwarf.h.        Experimental support for DWZ multifile forms 
208   DW_FORM_GNU_ref_alt        and DW_FORM_GNU_strp_alt.  Disabled by 
209   default.  Use configure        --enable-dwz to test it.
210 - readelf: Add .debug_macro parsing support.          Add .gdb_index 
211   version 7 parsing support.          Recognize DW_OP_GNU_parameter_ref.
212 - backends: Add support for Tilera TILE-Gx processor.
213 - translations: Updated Ukrainian translation.
214
215 * Fri Jun 22 2012 Mark Wielaard <mjw@redhat.com> 0.154-1
216 - libelf: [g]elf[32|64]_offscn() do not match SHT_NOBITS sections at 
217   OFFSET.
218 - libdw: dwarf_highpc function now handles DWARF 4 DW_AT_high_pc 
219   constant form.        Fix bug using dwarf_next_unit to iterate over 
220   .debug_types.
221 - elflint: Now accepts gold linker produced executables.
222 - The license is now GPLv2/LGPLv3+ for the libraries and GPLv3+ for 
223   stand-alone programs. There is now also a formal CONTRIBUTING 
224   document describing how to submit patches.
225
226 * Thu Feb 23 2012 Mark Wielaard <mjw@redhat.com> 0.153-1
227 - libdw: Support reading .zdebug_* DWARF sections compressed via zlib.
228 - libdwfl: Speed up dwfl_module_addrsym.
229 - nm: Support C++ demangling.
230 - ar: Support D modifier for "deterministic output" with no 
231   uid/gid/mtime info.     The U modifier is the inverse.     elfutils 
232   can be configured with the --enable-deterministic-archives     option 
233   to make the D behavior the default when U is not specified.
234 - ranlib: Support -D and -U flags with same meaning.
235 - readelf: Improve output of -wline. Add support for printing SDT elf 
236   notes.          Add printing of .gdb_index section.    Support for 
237   typed DWARF stack, call_site and entry_value.
238 - strip: Add --reloc-debug-sections option.        Improved SHT_GROUP 
239   sections handling.
240
241 * Tue Feb 15 2011  <drepper@gmail.com> 0.152-1
242 - Various build and warning nits fixed for newest GCC and Autoconf.
243 - libdwfl: Yet another prelink-related fix for another regression.
244          Look for Linux kernel images in files named with compression
245   suffixes.
246 - elfcmp: New flag --ignore-build-id to ignore differing build ID
247   bits.         New flag -l/--verbose to print all differences.
248
249 * Wed Jan 12 2011  <drepper@gmail.com> 0.151-1
250 - libdwfl: Fix for more prelink cases with separate debug file.
251 - strip: New flag --strip-sections to remove section headers entirely.
252
253 * Mon Nov 22 2010  <drepper@gmail.com> 0.150-1
254 - libdw: Fix for handling huge .debug_aranges section.
255 - libdwfl: Fix for handling prelinked DSO with separate debug file.
256 - findtextrel: Fix diagnostics to work with usual section ordering.
257 - libebl: i386 backend fix for multi-register integer return value
258   location.
259
260 * Mon Sep 13 2010  <drepper@redhat.com> 0.149-1
261 - libdw: Decode new DW_OP_GNU_implicit_pointer operation;        new
262   function dwarf_getlocation_implicit_pointer.
263 - libdwfl: New function dwfl_dwarf_line.
264 - addr2line: New flag -F/--flags to print more DWARF line information
265   details.
266 - strip: -g recognizes .gdb_index as a debugging section.
267
268 * Mon Jun 28 2010  <drepper@redhat.com> 0.148-1
269 - libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
270   dwarf_offdie_types.        New functions dwarf_lineisa,
271   dwarf_linediscriminator, dwarf_lineop_index.
272 - libdwfl: Fixes in core-file handling, support cores from PIEs.
273          When working from build IDs, don't open a named file that
274   mismatches.
275 - readelf: Handle DWARF 4 formats.
276
277 * Mon May  3 2010 Ulrich Drepper <drepper@redhat.com> 0.147-1
278 - libdw: Fixes in CFI handling, best possible handling of bogus CFA
279   ops.
280 - libdwfl: Ignore R_*_NONE relocs, works around old (binutils) ld -r
281   bugs.
282
283 * Wed Apr 21 2010  <drepper@redhat.com> 0.146-1
284 - libdwfl: New function dwfl_core_file_report.
285
286 * Tue Feb 23 2010 Ulrich Drepper <drepper@redhat.com> 0.145-1
287 - Fix build with --disable-dependency-tracking.
288 - Fix build with most recent glibc headers.
289 - libelf: More robust to bogus section headers.
290 - libdw: Fix CFI decoding.
291 - libdwfl: Fix address bias returned by CFI accessors.   Fix core
292   file module layout identification.
293 - readelf: Fix CFI decoding.
294
295 * Thu Jan 14 2010  <drepper@redhat.com> 0.144-1
296 - libelf: New function elf_getphdrnum.  Now support using more than
297   65536 program headers in a file.
298 - libdw: New function dwarf_aggregate_size for computing (constant)
299   type        sizes, including array_type cases with nontrivial
300   calculation.
301 - readelf: Don't give errors for missing info under -a.
302   Handle Linux "VMCOREINFO" notes under -n.
303
304 * Mon Sep 21 2009  <drepper@redhat.com> 0.143-1
305 - libdw: Various convenience functions for individual attributes now
306   use dwarf_attr_integrate to look up indirect inherited
307   attributes.  Location expression handling now supports
308   DW_OP_implicit_value.
309 - libdwfl: Support automatic decompression of files in XZ format,
310   and of Linux kernel images made with bzip2 or LZMA (as well
311   as gzip).
312
313 * Mon Jun 29 2009  <drepper@redhat.com> 0.142-1
314 - libelf: Add elf_getshdrnum alias for elf_getshnum and elf_getshdrstrndx alias
315   for elf_getshstrndx and deprecate original names.  Sun screwed up
316   their implementation and asked for a solution.
317 - libebl: Add support for STB_GNU_UNIQUE.
318 - elflint: Add support for STB_GNU_UNIQUE.
319 - readelf: Add -N option, speeds up DWARF printing without address->name lookups.
320 - libdw: Add support for decoding DWARF CFI into location description form.
321   Handle some new DWARF 3 expression operations previously omitted.
322   Basic handling of some new encodings slated for DWARF
323
324 * Thu Apr 23 2009 Ulrich Drepper <drepper@redhat.com> 0.141-1
325 - libebl: sparc backend fixes;  some more arm backend support
326 - libdwfl: fix dwfl_module_build_id for prelinked DSO case;
327   fixes in core file support;    dwfl_module_getsym interface
328   improved for non-address symbols
329 - strip: fix infinite loop on strange inputs with -f
330 - addr2line: take -j/--section=NAME option for binutils compatibility
331            (same effect as '(NAME)0x123' syntax already supported)
332
333 * Mon Feb 16 2009 Ulrich Drepper <drepper@redhat.com> 0.140-1
334 - libelf: Fix regression in creation of section header
335 - libdwfl: Less strict behavior if DWARF reader ist just used to
336   display data
337
338 * Thu Jan 22 2009 Ulrich Drepper <drepper@redhat.com> 0.139-1
339 - libcpu: Add Intel SSE4 disassembler support
340 - readelf: Implement call frame information and exception handling
341   dumping.          Add -e option.  Enable it implicitly for -a.
342 - elflint: Check PT_GNU_EH_FRAME program header entry.
343 - libdwfl: Support automatic gzip/bzip2 decompression of ELF files.
344
345 * Wed Dec 31 2008 Roland McGrath <roland@redhat.com> 0.138-1
346 - Install <elfutils/version.h> header file for applications to use in
347   source version compatibility checks.
348 - libebl: backend fixes for i386 TLS relocs; backend support for
349   NT_386_IOPERM
350 - libcpu: disassembler fixes
351 - libdwfl: bug fixes
352 - libelf: bug fixes
353 - nm: bug fixes for handling corrupt input files
354
355 * Tue Aug 26 2008 Ulrich Drepper <drepper@redhat.com> 0.137-1
356 - Minor fixes for unreleased 0.136 release.
357
358 * Mon Aug 25 2008 Ulrich Drepper <drepper@redhat.com> 0.136-1
359 - libdwfl: bug fixes; new segment interfaces;    all the libdwfl-based
360  tools now support --core=COREFILE option
361
362 * Mon May 12 2008 Ulrich Drepper <drepper@redhat.com> 0.135-1
363 - libdwfl: bug fixes
364 - strip: changed handling of ET_REL files wrt symbol tables and relocs
365
366 * Tue Apr  8 2008 Ulrich Drepper <drepper@redhat.com> 0.134-1
367 - elflint: backend improvements for sparc, alpha
368 - libdwfl, libelf: bug fixes
369
370 * Sat Mar  1 2008 Ulrich Drepper <drepper@redhat.com> 0.133-1
371 - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
372 - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
373 - libdwfl: bug fixes and optimization in relocation handling
374 - elfcmp: bug fix for non-allocated section handling
375 - ld: implement newer features of binutils linker.
376
377 * Mon Jan 21 2008 Ulrich Drepper <drepper@redhat.com> 0.132-1
378 - libcpu: Implement x86 and x86-64 disassembler.
379 - libasm: Add interface for disassembler.
380 - all programs: add debugging of branch prediction.
381 - libelf: new function elf_scnshndx.
382
383 * Sun Nov 11 2007 Ulrich Drepper <drepper@redhat.com> 0.131-1
384 - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now depreca
385 ted;       bug fixes for oddly-formatted DWARF
386 - libdwfl: bug fixes in offline archive support, symbol table handling;
387          apply partial relocations for dwfl_module_address_section on
388 ET_REL
389 - libebl: powerpc backend support for Altivec registers
390
391 * Mon Oct 15 2007 Ulrich Drepper <drepper@redhat.com> 0.130-1
392 - readelf: -p option can take an argument like -x for one section,
393          or no argument (as before) for all SHF_STRINGS sections;
394          new option --archive-index (or -c);     improved -n output fo
395 r core files, on many machines
396 - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
397         new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
398 - readelf, elflint: handle SHT_NOTE sections without requiring phdrs
399 - elflint: stricter checks on debug sections
400 - libdwfl: new functions dwfl_build_id_find_elf, dwfl_build_id_find_debu
401 ginfo,   dwfl_module_build_id, dwfl_module_report_build_id;      suppo
402 rt dynamic symbol tables found via phdrs;        dwfl_standard_find_de
403 buginfo now uses build IDs when available
404 - unstrip: new option --list (or -n)
405 - libebl: backend improvements for sparc, alpha, powerpc
406
407 * Tue Aug 14 2007 Ulrich Drepper <drepper@redhat.com> 0.129-1
408 - readelf: new options --hex-dump (or -x), --strings (or -p)
409 - addr2line: new option --symbols (or -S)
410
411 * Wed Apr 18 2007 Ulrich Drepper <drepper@redhat.com> 0.127-1
412 - libdw: new function dwarf_getsrcdirs
413 - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
414          dwfl_module_address_section
415
416 * Mon Feb  5 2007 Ulrich Drepper <drepper@redhat.com> 0.126-1
417 - new program: ar
418
419 * Mon Dec 18 2006 Ulrich Drepper <drepper@redhat.com> 0.125-1
420 - elflint: Compare DT_GNU_HASH tests.
421 - move archives into -static RPMs
422 - libelf, elflint: better support for core file handling
423
424 * Tue Oct 10 2006 Ulrich Drepper <drepper@redhat.com> 0.124-1
425 - libebl: sparc backend support for return value location
426 - libebl, libdwfl: backend register name support extended with more info
427 - libelf, libdw: bug fixes for unaligned accesses on machines that care
428 - readelf, elflint: trivial bugs fixed
429
430 * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
431 - libebl: Backend build fixes, thanks to Stepan Kasal.
432 - libebl: ia64 backend support for register names, return value location
433 - libdwfl: Handle truncated linux kernel module section names.
434 - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
435 - elflint: Fix checks to permit --hash-style=gnu format.
436
437 * Wed Jul 12 2006 Ulrich Drepper <drepper@redhat.com> 0.122-1
438 - libebl: add function to test for relative relocation
439 - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
440 - elflint, readelf: add support for DT_GNU_HASHlibelf: add elf_gnu_hash
441 - elflint, readelf: add support for 64-bit SysV-style hash tables
442 - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
443
444 * Wed Jun 14 2006  <drepper@redhat.com> 0.121-1
445 - libelf: bug fixes for rewriting existing files when using mmap.
446 - make all installed headers usable in C++ code.
447 - readelf: better output format.
448 - elflint: fix tests of dynamic section content.
449 - ld: Implement --as-needed, --execstack, PT_GNU_STACK.  Many small patc
450 hes.
451 - libdw, libdwfl: handle files without aranges info.
452
453 * Tue Apr  4 2006 Ulrich Drepper <drepper@redhat.com> 0.120-1
454 - Bug fixes.
455 - dwarf.h updated for DWARF 3.0 final specification.
456 - libdwfl: New function dwfl_version.
457 - The license is now GPL for most files.  The libelf, libebl, libdw,and
458 libdwfl libraries have additional exceptions.  Add reference toOIN.
459
460 * Thu Jan 12 2006 Roland McGrath <roland@redhat.com> 0.119-1
461 - elflint: more tests.
462 - libdwfl: New function dwfl_module_register_names.
463 - libebl: New backend hook for register names.
464
465 * Tue Dec  6 2005 Ulrich Drepper <drepper@redhat.com> 0.118-1
466 - elflint: more tests.
467 - libdwfl: New function dwfl_module_register_names.
468 - libebl: New backend hook for register names.
469
470 * Thu Nov 17 2005 Ulrich Drepper <drepper@redhat.com> 0.117-1
471 - libdwfl: New function dwfl_module_return_value_location.
472 - libebl: Backend improvements for several CPUs.
473
474 * Mon Oct 31 2005 Ulrich Drepper <drepper@redhat.com> 0.116-1
475 - libdw: New functions dwarf_ranges, dwarf_entrypc, dwarf_diecu,       d
476 warf_entry_breakpoints.  Removed Dwarf_Func type and functions       d
477 warf_func_name, dwarf_func_lowpc, dwarf_func_highpc,       dwarf_func_
478 entrypc, dwarf_func_die; dwarf_getfuncs callback now uses       Dwarf_
479 Die, and dwarf_func_file, dwarf_func_line, dwarf_func_col       replac
480 ed by dwarf_decl_file, dwarf_decl_line, dwarf_decl_column;       dwarf
481 _func_inline, dwarf_func_inline_instances now take Dwarf_Die.       Ty
482 pe Dwarf_Loc renamed to Dwarf_Op; dwarf_getloclist,       dwarf_addrlo
483 clists renamed dwarf_getlocation, dwarf_getlocation_addr.
484
485 * Fri Sep  2 2005 Ulrich Drepper <drepper@redhat.com> 0.115-1
486 - libelf: speed-ups of non-mmap reading.
487 - strings: New program.
488 - Implement --enable-gcov option for configure.
489 - libdw: New function dwarf_getscopes_die.
490
491 * Wed Aug 24 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
492 - libelf: new function elf_getaroff
493 - libdw: Added dwarf_func_die, dwarf_func_inline, dwarf_func_inline_inst
494 ances.
495 - libdwfl: New functions dwfl_report_offline, dwfl_offline_section_addre
496 ss,      dwfl_linux_kernel_report_offline.
497 - ranlib: new program
498
499 * Mon Aug 15 2005 Ulrich Drepper <drepper@redhat.com> 0.114-1
500 - libelf: new function elf_getaroff
501 - ranlib: new program
502
503 * Wed Aug 10 2005 Ulrich Drepper <@redhat.com> 0.113-1
504 - elflint: relax a bit. Allow version definitions for defined symbols ag
505 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
506 sectionto have STRINGS and MERGE flag set.
507 - strip: add some more compatibility with binutils.
508
509 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
510 - elflint: relax a bit. Allow version definitions for defined symbols ag
511 ainstDSO versions also for symbols in nobits sections.  Allow .rodata
512 sectionto have STRINGS and MERGE flag set.
513
514 * Sat Aug  6 2005 Ulrich Drepper <@redhat.com> 0.113-1
515 - elflint: relax a bit. Allow version definitions for defined symbols ag
516 ainstDSO versions also for symbols in nobits sections.
517
518 * Fri Aug  5 2005 Ulrich Drepper <@redhat.com> 0.112-1
519 - elfcmp: some more relaxation.
520 - elflint: many more tests, especially regarding to symbol versioning.
521 - libelf: Add elfXX_offscn and gelf_offscn.
522 - libasm: asm_begin interface changes.
523 - libebl: Add three new interfaces to directly access machine, class, an
524 ddata encoding information.
525 - objdump: New program.  Just the beginning.
526
527 * Thu Jul 28 2005 Ulrich Drepper <@redhat.com> 0.111-1
528 - libdw: now contains all of libdwfl.  The latter is not installed anymore.
529 - elfcmp: little usability tweak, name and index of differing section is
530  printed.
531
532 * Sun Jul 24 2005 Ulrich Drepper <@redhat.com> 0.110-1
533 - libelf: fix a numbe rof problems with elf_update
534 - elfcmp: fix a few bugs.  Compare gaps.
535 - Fix a few PLT problems and mudflap build issues.
536 - libebl: Don't expose Ebl structure definition in libebl.h.  It's now p
537 rivate.
538
539 * Thu Jul 21 2005 Ulrich Drepper <@redhat.com> 0.109-1
540 - libebl: Check for matching modules.
541 - elflint: Check that copy relocations only happen for OBJECT or NOTYPE
542 symbols.
543 - elfcmp: New program.
544 - libdwfl: New library.
545
546 * Mon May  9 2005 Ulrich Drepper <@redhat.com> 0.108-1
547 - strip: fix bug introduced in last change
548 - libdw: records returned by dwarf_getsrclines are now sorted by address
549
550 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.108-1
551 - strip: fix bug introduced in last change
552
553 * Sun May  8 2005 Ulrich Drepper <@redhat.com> 0.107-1
554 - readelf: improve DWARF output format
555 - strip: support Linux kernel modules
556
557 * Fri Apr 29 2005 Ulrich Drepper <drepper@redhat.com> 0.107-1
558 - readelf: improve DWARF output format
559
560 * Mon Apr  4 2005 Ulrich Drepper <drepper@redhat.com> 0.106-1
561 - libdw: Updated dwarf.h from DWARF3 speclibdw: add new funtions dwarf_f
562 unc_entrypc, dwarf_func_file, dwarf_func_line,dwarf_func_col, dwarf_ge
563 tsrc_file
564
565 * Fri Apr  1 2005 Ulrich Drepper <drepper@redhat.com> 0.105-1
566 - addr2line: New program
567 - libdw: add new functions: dwarf_addrdie, dwarf_macro_*, dwarf_getfuncs
568 ,dwarf_func_*.
569 - findtextrel: use dwarf_addrdie
570
571 * Mon Mar 28 2005 Ulrich Drepper <drepper@redhat.com> 0.104-1
572 - findtextrel: New program.
573
574 * Mon Mar 21 2005 Ulrich Drepper <drepper@redhat.com> 0.103-1
575 - libdw: Fix using libdw.h with gcc < 4 and C++ code.  Compiler bug.
576
577 * Tue Feb 22 2005 Ulrich Drepper <drepper@redhat.com> 0.102-1
578 - More Makefile and spec file cleanups.
579
580 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
581 - upgrade to 0.94
582
583 * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
584 - upgrade to 0.93
585
586 * Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
587 - full version
588 - macroized spec file for GPL or OSL builds
589 - include only libelf under GPL plus wrapper scripts
590
591 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
592 - macroized spec file for GPL or OSL builds
593
594 * Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
595 - split elfutils-devel into two packages.
596
597 * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
598 - include only libelf under GPL plus wrapper scripts
599
600 * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
601 - readelf, not readline, in %%description (#111214).
602
603 * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
604 - update to 0.89 (fix eu-strip)
605
606 * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
607 - update to 0.86 (fix eu-strip on s390x/alpha)
608 - libebl is an archive now; remove references to DSO
609
610 * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
611 - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
612
613 * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
614 - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
615
616 * Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
617 - upgrade to 0.82 (strip tests fixed on big-endian).
618
619 * Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
620 - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
621
622 * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
623 - upgrade to 0.80 (debugedit changes for kernel in progress).
624
625 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
626 - rebuilt
627
628 * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
629 - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
630
631 * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
632 - upgrade to 0.78 (libdwarf bugfix, libdw additions).
633
634 * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
635 - debuginfo rebuild
636
637 * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
638 - use the correct way of identifying the section via the sh_info link.
639
640 * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
641 - update to 0.75 (eu-strip -g fix)
642
643 * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
644 - update to 0.74 (fix for writing with some non-dirty sections)
645
646 * Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
647 - another -0.73 update (with sparc fixes).
648 - do "make check" in %%check, not %%install, section.
649
650 * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
651 - update to 0.73 (with s390 fixes).
652
653 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
654 - rebuilt
655
656 * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
657 - fix arguments to gelf_getsymshndx and elf_getshstrndx
658 - fix other warnings
659 - reenable checks on s390x
660
661 * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
662 - temporarily disable checks on s390x, until someone has
663   time to look at it
664
665 * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
666 - update to 0.72
667
668 * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
669 - update to 0.71
670
671 * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
672 - update to 0.69.
673 - add "make check" and segfault avoidance patch.
674 - elfutils-libelf needs to run ldconfig.
675
676 * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
677 - update to 0.68.
678
679 * Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
680 - update to 0.67.
681
682 * Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
683 - update to 0.65.
684
685 * Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
686 - update to 0.64.
687
688 * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
689 - split packages further into elfutils-libelf
690
691 * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
692 - update to 0.63.
693
694 * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
695 - Adjust for dropping libtool
696
697 * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
698 - update to 0.59
699
700 * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
701 - update to 0.56
702
703 * Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
704 - update to 0.54
705
706 * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
707 - update to 0.53
708 - drop x86_64 hack, ICE fixed in gcc-3.2-11.
709
710 * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
711 - get beehive to punch a rhpkg generated package.
712
713 * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
714 - build in 8.0.1.
715 - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
716
717 * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
718 - Add libelf-devel to conflicts for elfutils-devel
719
720 * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
721 - Split into runtime and devel package
722
723 * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
724 - integrate into official sources
725
726 * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
727 - Swaddle.