changelog/NEWS update
[platform/upstream/dracut.git] / dracut.spec
1 %if 0%{?fedora} < 12
2 %define with_switch_root 1
3 %else
4 %define with_switch_root 0
5 %endif
6
7 %if %{defined gittag}
8 %define rdist .git%{gittag}%{?dist}
9 %define dashgittag -%{gittag}
10 %else
11 %define rdist %{?dist}
12 %endif
13
14 Name: dracut
15 Version: 001
16 Release: 9%{?rdist}
17 Summary: Initramfs generator using udev
18 Group: System Environment/Base          
19 License: GPLv2+ 
20 URL: http://apps.sourceforge.net/trac/dracut/wiki
21 Source0: dracut-%{version}%{?dashgittag}.tar.bz2
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23 Requires: udev
24 Requires: util-linux-ng
25 Requires: module-init-tools >= 3.7-9
26 Requires: cpio
27 Requires: coreutils
28 Requires: findutils
29 Requires: binutils
30 Requires: grep
31 Requires: which
32 Requires: mktemp >= 1.5-5
33 Requires: mount
34 Requires: bash
35 Requires: dash
36 Requires: /bin/sh 
37 Requires: fileutils, gzip, tar
38 Requires: lvm2 >= 2.02.33-9, dhclient
39 Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts >= 8.63-1
40 Requires: e2fsprogs >= 1.38-12, libselinux, libsepol, coreutils
41 Requires: mdadm, elfutils-libelf, plymouth >= 0.7.0
42 Requires: cryptsetup-luks
43 Requires: file
44 Requires: bzip2
45 Requires: dmraid
46 Requires: kbd
47 Requires: plymouth-scripts
48
49 %if ! 0%{?with_switch_root}
50 Requires: util-linux-ng >= 2.16
51 BuildArch: noarch
52 %endif
53
54 %description
55 dracut is a new, event-driven initramfs infrastructure based around udev.
56
57 %package network
58 Summary: dracut modules to build a dracut initramfs with network support
59 Requires: %{name} = %{version}-%{release}
60 Requires: rpcbind nfs-utils 
61 Requires: iscsi-initiator-utils
62 Requires: nbd
63 Requires: net-tools iproute
64 Requires: bridge-utils
65
66 %description network
67 This package requires everything which is needed to build a generic
68 all purpose initramfs with network support with dracut.
69
70 %package generic
71 Summary: Metapackage to build a generic initramfs with dracut
72 Requires: %{name} = %{version}-%{release}
73 Requires: %{name}-network = %{version}-%{release}
74
75 %description generic
76 This package requires everything which is needed to build a generic
77 all purpose initramfs with dracut.
78
79
80 %package kernel
81 Summary: Metapackage to build generic initramfs with dracut with only kernel modules
82 Requires: %{name} = %{version}-%{release}
83 Requires: ql2100-firmware
84 Requires: ql2200-firmware
85 Requires: ql23xx-firmware
86 Requires: ql2400-firmware
87 Requires: ql2500-firmware
88
89 %description kernel
90 This package requires everything which is needed to build a initramfs with all
91 kernel modules and firmware files needed by dracut modules.
92
93 %package tools
94 Summary: dracut tools to build the local initramfs
95 Requires: coreutils cryptsetup-luks device-mapper
96 Requires: diffutils dmraid findutils gawk grep lvm2
97 Requires: module-init-tools sed
98 Requires: cpio gzip
99
100 %description tools
101 This package contains tools to assemble the local initrd and host configuration.
102
103 %prep
104 %setup -q -n %{name}-%{version}%{?dashgittag}
105
106 %build
107 make
108
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
113      sysconfdir=/etc mandir=%{_mandir}
114
115 %if ! 0%{?with_switch_root}
116 rm -f $RPM_BUILD_ROOT/sbin/switch_root
117 %endif
118
119 mkdir -p $RPM_BUILD_ROOT/boot/dracut
120 mkdir -p $RPM_BUILD_ROOT/var/lib/dracut/overlay
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,0755)
127 %doc README HACKING TODO COPYING AUTHORS NEWS
128 /sbin/dracut
129 %if 0%{?with_switch_root}
130 /sbin/switch_root
131 %endif
132 %dir %{_datadir}/dracut
133 %{_datadir}/dracut/dracut-functions
134 %config(noreplace) /etc/dracut.conf
135 %{_mandir}/man8/dracut.8*
136 %{_datadir}/dracut/modules.d/00dash
137 %{_datadir}/dracut/modules.d/10redhat-i18n
138 %{_datadir}/dracut/modules.d/10rpmversion
139 %{_datadir}/dracut/modules.d/50plymouth
140 %{_datadir}/dracut/modules.d/90crypt
141 %{_datadir}/dracut/modules.d/90dmraid
142 %{_datadir}/dracut/modules.d/90dmsquash-live
143 %{_datadir}/dracut/modules.d/90kernel-modules
144 %{_datadir}/dracut/modules.d/90lvm
145 %{_datadir}/dracut/modules.d/90mdraid
146 %{_datadir}/dracut/modules.d/95debug
147 %{_datadir}/dracut/modules.d/95resume
148 %{_datadir}/dracut/modules.d/95rootfs-block
149 %{_datadir}/dracut/modules.d/95s390
150 %{_datadir}/dracut/modules.d/95terminfo
151 %{_datadir}/dracut/modules.d/95udev-rules
152 %{_datadir}/dracut/modules.d/95udev-rules.ub810
153 %{_datadir}/dracut/modules.d/98syslog
154 %{_datadir}/dracut/modules.d/99base
155
156 %files network
157 %defattr(-,root,root,0755)
158 %{_datadir}/dracut/modules.d/40network
159 %{_datadir}/dracut/modules.d/95fcoe
160 %{_datadir}/dracut/modules.d/95iscsi
161 %{_datadir}/dracut/modules.d/95nbd
162 %{_datadir}/dracut/modules.d/95nfs
163
164 %files kernel 
165 %defattr(-,root,root,0755)
166 %doc README.kernel
167
168 %files generic
169 %defattr(-,root,root,0755)
170 %doc README.generic
171
172 %files tools 
173 %defattr(-,root,root,0755)
174 %doc COPYING NEWS
175 /sbin/dracut-gencmdline
176 /sbin/dracut-catimages
177 %dir /boot/dracut
178 %dir /var/lib/dracut
179 %dir /var/lib/dracut/overlay
180
181 %changelog
182 * Tue Sep 15 2009 Harald Hoyer <harald@redhat.com> 001-9
183 - add ifname= argument for persistent netdev names
184 - new /initqueue-finished to check if the main loop can be left
185 - copy mdadm.conf if --mdadmconf set or mdadmconf in dracut.conf
186
187 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-8
188 - plymouth: use plymouth-populate-initrd
189 - add add_drivers for dracut and dracut.conf
190 - do not mount /proc and /selinux manually in selinux-load-policy
191
192 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-7
193 - add scsi_wait_scan to be sure everything was scanned
194
195 * Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-6
196 - fixed several problems with md raid containers
197 - fixed selinux policy loading
198
199 * Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-5
200 - patch does not honor file modes, fixed them manually
201
202 * Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-4
203 - fixed mdraid for IMSM
204
205 * Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-3
206 - fixed bug, which prevents installing 61-persistent-storage.rules (bug #520109)
207
208 * Thu Sep 03 2009 Harald Hoyer <harald@redhat.com> 001-2
209 - fixed missing grep for md
210 - reorder cleanup
211
212 * Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
213 - version 001
214 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
215
216 * Fri Aug 14 2009 Harald Hoyer <harald@redhat.com> 0.9-1
217 - version 0.9
218
219 * Thu Aug 06 2009 Harald Hoyer <harald@redhat.com> 0.8-1
220 - version 0.8 
221 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
222
223 * Fri Jul 24 2009 Harald Hoyer <harald@redhat.com> 0.7-1
224 - version 0.7
225 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
226
227 * Wed Jul 22 2009 Harald Hoyer <harald@redhat.com> 0.6-1
228 - version 0.6
229 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
230
231 * Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
232 - version 0.5
233 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
234
235 * Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
236 - version 0.4
237 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
238
239 * Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
240 - version 0.3
241 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
242
243 * Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
244 - version 0.2
245
246 * Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
247 - first release
248
249 * Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
250 - Initial build
251