Refresh upstream 2.1.0 release
[profile/ivi/libgsignon-glib.git] / dists / rpm / libgsignon-glib-tizen.spec
1 #define dbus bus type to use [p2p, session, system]
2 %define dbus_type p2p
3
4 Name:       libgsignon-glib
5 Summary:    GLib API for the SSO framework
6 Version:    2.1.0
7 Release:    2
8 Group:      Security/Accounts
9 License:    LGPL-2.1
10 Source:     %{name}-%{version}.tar.gz
11 URL: https://01.org/gsso
12 Requires: dbus-1
13 Requires: gsignon
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 BuildRequires:  pkgconfig(check)
17 BuildRequires:  pkgconfig(glib-2.0)
18 BuildRequires:  pkgconfig(gobject-2.0)
19 BuildRequires:  pkgconfig(gio-2.0)
20
21 %description
22 %{summary}.
23
24
25 %package devel
26 Summary:    Development files for %{name}
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 %{summary}.
32
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37
38 %build
39 %configure --enable-dbus-type=%{dbus_type}
40 make %{?_smp_mflags}
41
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47
48 %post -p /sbin/ldconfig
49
50
51 %postun -p /sbin/ldconfig
52
53
54 %files
55 %defattr(-,root,root,-)
56 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
57 %{_libdir}/%{name}.so.*
58
59
60 %files devel
61 %defattr(-,root,root,-)
62 %{_includedir}/%{name}/*.h
63 %{_libdir}/%{name}.so
64 %{_libdir}/pkgconfig/%{name}.pc
65 %{_datadir}/gtk-doc/html/%{name}/*
66 %{_bindir}/gsso-example
67