Release 2.0.2
[profile/ivi/libgsignon-glib.git] / dists / rpm / libgsignon-glib-tizen.spec
1 #define dbus bus type to use [p2p, session, system]
2 %define dbus_type p2p
3
4 Name:       libgsignon-glib
5 Summary:    GLib API for the SSO framework
6 Version:    2.0.2
7 Release:    4
8 Group:      System/Libraries
9 License:    LGPL-2.1+
10 Source:     %{name}-%{version}.tar.gz
11 URL: https://01.org/gsso
12 Requires: dbus-1
13 Requires: gsignon
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 BuildRequires:  pkgconfig(check)
17 BuildRequires:  pkgconfig(glib-2.0)
18 BuildRequires:  pkgconfig(gobject-2.0)
19 BuildRequires:  pkgconfig(gio-2.0)
20 BuildRequires:  gobject-introspection
21
22 %description
23 %{summary}.
24
25
26 %package devel
27 Summary:    Development files for %{name}
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 %{summary}.
33
34
35 %prep
36 %setup -q -n %{name}-%{version}
37 if [ -f = "gtk-doc.make" ]
38 then
39 rm gtk-doc.make
40 fi
41 touch gtk-doc.make
42 autoreconf -f -i
43
44
45 %build
46 %configure --enable-dbus-type=%{dbus_type}
47 make %{?_smp_mflags}
48
49
50 %install
51 rm -rf %{buildroot}
52 %make_install
53
54
55 %post -p /sbin/ldconfig
56
57
58 %postun -p /sbin/ldconfig
59
60
61 %files
62 %defattr(-,root,root,-)
63 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
64 %{_libdir}/%{name}.so.*
65
66
67 %files devel
68 %defattr(-,root,root,-)
69 %{_includedir}/%{name}/*.h
70 %{_libdir}/%{name}.so
71 %{_libdir}/pkgconfig/%{name}.pc
72 %{_libdir}/girepository-1.0/gSignon-1.0.typelib
73 %{_datadir}/gir-1.0/gSignon-1.0.gir
74 %{_datadir}/gtk-doc/html/%{name}/*
75 %{_bindir}/gsso-example
76