updaetd disto specific files/folders
[profile/ivi/libgsignon-glib.git] / dists / rpm / libgsignon-glib-suse.spec
1 #define dbus bus type to use [p2p, session, system]
2 %define dbus_type session
3
4 Name:       libgsignon-glib
5 Summary:    GLib API for the SSO framework
6 Version:    2.0.0
7 Release:    1
8 Group:      System/Libraries
9 License:    LGPL
10 Source:     %{name}-%{version}.tar.gz
11 Requires: dbus-1
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 BuildRequires:  pkgconfig(gtk-doc)
15 BuildRequires:  pkgconfig(check)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(gobject-2.0)
18 BuildRequires:  pkgconfig(gio-2.0)
19 BuildRequires:  gobject-introspection
20
21 %description
22 %{summary}.
23
24
25 %package devel
26 Summary:    Development files for %{name}
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 %{summary}.
32
33
34 %prep
35 %setup -q -n %{name}-%{version}
36 gtkdocize
37 autoreconf -f -i
38
39
40 %build
41 %configure \
42         --enable-gtk-doc \
43         --enable-gtk-doc-html \
44         --enable-python \
45         --enable-dbus-type=%{dbus_type}
46 make %{?_smp_mflags}
47
48
49 %install
50 rm -rf %{buildroot}
51 %make_install
52
53
54 %post -p /sbin/ldconfig
55
56
57 %postun -p /sbin/ldconfig
58
59
60 %files
61 %defattr(-,root,root,-)
62 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
63 %{_libdir}/%{name}.so.*
64
65
66 %files devel
67 %defattr(-,root,root,-)
68 %{_includedir}/%{name}/*.h
69 %{_libdir}/%{name}.so
70 %{_libdir}/%{name}.la
71 %{_libdir}/pkgconfig/%{name}.pc
72 %{_libdir}/girepository-1.0/gSignon-1.0.typelib
73 %{_datadir}/gir-1.0/gSignon-1.0.gir
74 #%{_datadir}/vala/vapi/gsignon.vapi
75 %{_datadir}/gtk-doc/html/%{name}/*
76
77
78 %changelog
79 * Mon Feb 11 2013 Jussi Laako <jussi.laako@linux.intel.com> - 2.0
80 - Refresh for the libgsignon-glib
81