Assorted fixes and cleanups, updated version
[platform/upstream/gsignond.git] / dists / rpm / gsignond-suse.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type session
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.4
10 Release: 2
11 Group: System/Daemons
12 License: LGPL-2.1+
13 Source: %{name}-%{version}.tar.gz
14 URL: https://01.org/gsso
15 Provides: gsignon
16 %if %{dbus_type} != "p2p"
17 Requires: dbus-1
18 %endif
19 Requires(post): /sbin/ldconfig
20 Requires(postun): /sbin/ldconfig
21 BuildRequires: pkgconfig(dbus-1)
22 BuildRequires: pkgconfig(gtk-doc)
23 BuildRequires: pkgconfig(glib-2.0) >= 2.30
24 BuildRequires: pkgconfig(gobject-2.0)
25 BuildRequires: pkgconfig(gio-2.0)
26 BuildRequires: pkgconfig(gio-unix-2.0)
27 BuildRequires: pkgconfig(gmodule-2.0)
28 BuildRequires: pkgconfig(sqlite3)
29
30
31 %description
32 %{summary}.
33
34
35 %package devel
36 Summary:    Development files for %{name}
37 Group:      Development/Libraries
38 Requires:   %{name} = %{version}-%{release}
39
40 %description devel
41 %{summary}.
42
43
44 %package doc
45 Summary:    Documentation files for %{name}
46 Group:      Development/Libraries
47 Requires:   %{name} = %{version}-%{release}
48
49 %description doc
50 %{summary}.
51
52
53 %prep
54 %setup -q -n %{name}-%{version}
55 #gtkdocize
56 # for repository snapshot packages
57 #aclocal
58 #autoheader
59 #libtoolize --copy --force
60 #autoconf
61 #automake --add-missing --copy
62 #autoreconf --install --force
63 # fore release source packages
64 autoreconf -f -i
65
66
67 %build
68 %if %{debug_build} == 1
69 %configure --enable-dbus-type=%{dbus_type} --enable-debug
70 %else
71 %configure --enable-dbus-type=%{dbus_type}
72 %endif
73
74 make %{?_smp_mflags}
75
76
77 %install
78 rm -rf %{buildroot}
79 %make_install
80
81
82 %post
83 /sbin/ldconfig
84 chmod u+s %{_bindir}/%{name}
85 groupadd -f -r gsignond
86
87
88 %postun -p /sbin/ldconfig
89
90
91 %files
92 %defattr(-,root,root,-)
93 %doc AUTHORS COPYING.LIB INSTALL NEWS README
94 %{_bindir}/%{name}
95 %{_bindir}/%{name}-plugind
96 %{_libdir}/lib%{name}-*.so.*
97 %{_libdir}/%{name}/extensions/*.so*
98 %{_libdir}/%{name}/plugins/*.so*
99 %if %{dbus_type} != "p2p"
100 %{_datadir}/dbus-1/services/*SingleSignOn*.service
101 %endif
102 %exclude %{_libdir}/gsignond/extensions/*.la
103 %exclude %{_libdir}/gsignond/plugins/*.la
104 %config(noreplace) %{_sysconfdir}/gsignond.conf
105
106
107 %files devel
108 %defattr(-,root,root,-)
109 %{_includedir}/%{name}/*.h
110 %{_libdir}/lib%{name}-*.so
111 %{_libdir}/lib%{name}-*.la
112 %{_libdir}/pkgconfig/%{name}.pc
113 %if %{dbus_type} != "p2p"
114 %{_datadir}/dbus-1/interfaces/*SSO*.xml
115 %endif
116
117
118 %files doc
119 %defattr(-,root,root,-)
120 %{_datadir}/gtk-doc/html/gsignond/*
121
122
123 %changelog
124 * Fri Feb 28 2014 Jussi Laako <jussi.laako@linux.intel.com>
125 - Release 0.0.4
126
127 * Thu Aug 22 2013 Amarnath Valluri <amarnath.valluri@linux.intel.com>
128 - Release 0.0.3
129 - Bug fixes in UI interaction
130 - Documentation support
131
132 * Mon Jun 24 2013 Imran Zaman <imran.zaman@intel.com>
133 - Release 0.0.2 that comprises of bug fixes
134
135 * Wed Jun 12 2013 Jussi Laako <jussi.laako@linux.intel.com>
136 - Prepare for first release
137
138 * Thu Feb 08 2013 Jussi Laako <jussi.laako@linux.intel.com>
139 - Initial RPM packaging
140