Release 0.0.2
[platform/upstream/gsignond.git] / dists / rpm / gsignond-suse.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type session
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.2
10 Release: 9
11 Group: System/Daemons
12 License: LGPL
13 Source: %{name}-%{version}.tar.gz
14 %if %{dbus_type} != "p2p"
15 Requires: dbus-1
16 %endif
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 BuildRequires: pkgconfig(dbus-1)
20 BuildRequires: pkgconfig(gtk-doc)
21 BuildRequires: pkgconfig(glib-2.0) >= 2.30
22 BuildRequires: pkgconfig(gobject-2.0)
23 BuildRequires: pkgconfig(gio-2.0)
24 BuildRequires: pkgconfig(gio-unix-2.0)
25 BuildRequires: pkgconfig(gmodule-2.0)
26 BuildRequires: pkgconfig(sqlite3)
27
28
29 %description
30 %{summary}.
31
32
33 %package devel
34 Summary:    Development files for %{name}
35 Group:      Development/Libraries
36 Requires:   %{name} = %{version}-%{release}
37
38 %description devel
39 %{summary}.
40
41
42 %prep
43 %setup -q -n %{name}-%{version}
44 #gtkdocize
45 # for repository snapshot packages
46 #aclocal
47 #autoheader
48 #libtoolize --copy --force
49 #autoconf
50 #automake --add-missing --copy
51 #autoreconf --install --force
52 # fore release source packages
53 autoreconf -f -i
54
55
56 %build
57 %if %{debug_build} == 1
58 %configure --enable-dbus-type=%{dbus_type} --enable-debug
59 %else
60 %configure --enable-dbus-type=%{dbus_type}
61 %endif
62
63 make %{?_smp_mflags}
64
65
66 %install
67 rm -rf %{buildroot}
68 %make_install
69
70
71 %post
72 /sbin/ldconfig
73 chmod u+s %{_bindir}/%{name}
74
75
76 %postun -p /sbin/ldconfig
77
78
79 %files
80 %defattr(-,root,root,-)
81 %doc AUTHORS COPYING.LIB INSTALL NEWS README
82 %{_bindir}/%{name}
83 %{_bindir}/%{name}-plugind
84 %{_libdir}/lib%{name}-*.so.*
85 %{_libdir}/%{name}/extensions/*.so*
86 %{_libdir}/%{name}/plugins/*.so*
87 %if %{dbus_type} != "p2p"
88 %{_datadir}/dbus-1/services/*SingleSignOn*.service
89 %endif
90 %exclude %{_libdir}/gsignond/extensions/*.la
91 %exclude %{_libdir}/gsignond/plugins/*.la
92
93
94 %files devel
95 %defattr(-,root,root,-)
96 %{_includedir}/%{name}/*.h
97 %{_libdir}/lib%{name}-*.so
98 %{_libdir}/lib%{name}-*.la
99 %{_libdir}/pkgconfig/%{name}.pc
100 %if %{dbus_type} != "p2p"
101 %{_datadir}/dbus-1/interfaces/*SSO*.xml
102 %endif
103
104
105 %changelog
106 * Mon Jun 24 2013 Imran Zaman <imran.zaman@intel.com>
107 - Release 0.0.2 that comprises of bug fixes
108
109 * Wed Jun 12 2013 Jussi Laako <jussi.laako@linux.intel.com>
110 - Prepare for first release
111
112 * Thu Feb 08 2013 Jussi Laako <jussi.laako@linux.intel.com>
113 - Initial RPM packaging
114