Release 0.0.3-1
[platform/upstream/gsignond.git] / dists / rpm / gsignond-suse.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type session
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.3
10 Release: 1
11 Group: System/Daemons
12 License: LGPL-2.1+
13 Source: %{name}-%{version}.tar.gz
14 Provides: gsignon
15 %if %{dbus_type} != "p2p"
16 Requires: dbus-1
17 %endif
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
20 BuildRequires: pkgconfig(dbus-1)
21 BuildRequires: pkgconfig(gtk-doc)
22 BuildRequires: pkgconfig(glib-2.0) >= 2.30
23 BuildRequires: pkgconfig(gobject-2.0)
24 BuildRequires: pkgconfig(gio-2.0)
25 BuildRequires: pkgconfig(gio-unix-2.0)
26 BuildRequires: pkgconfig(gmodule-2.0)
27 BuildRequires: pkgconfig(sqlite3)
28
29
30 %description
31 %{summary}.
32
33
34 %package devel
35 Summary:    Development files for %{name}
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38
39 %description devel
40 %{summary}.
41
42
43 %package doc
44 Summary:    Documentation files for %{name}
45 Group:      Development/Libraries
46 Requires:   %{name} = %{version}-%{release}
47
48 %description doc
49 %{summary}.
50
51
52 %prep
53 %setup -q -n %{name}-%{version}
54 #gtkdocize
55 # for repository snapshot packages
56 #aclocal
57 #autoheader
58 #libtoolize --copy --force
59 #autoconf
60 #automake --add-missing --copy
61 #autoreconf --install --force
62 # fore release source packages
63 autoreconf -f -i
64
65
66 %build
67 %if %{debug_build} == 1
68 %configure --enable-dbus-type=%{dbus_type} --enable-debug
69 %else
70 %configure --enable-dbus-type=%{dbus_type}
71 %endif
72
73 make %{?_smp_mflags}
74
75
76 %install
77 rm -rf %{buildroot}
78 %make_install
79
80
81 %post
82 /sbin/ldconfig
83 chmod u+s %{_bindir}/%{name}
84 groupadd -f -r gsignond
85
86
87 %postun -p /sbin/ldconfig
88
89
90 %files
91 %defattr(-,root,root,-)
92 %doc AUTHORS COPYING.LIB INSTALL NEWS README
93 %{_bindir}/%{name}
94 %{_bindir}/%{name}-plugind
95 %{_libdir}/lib%{name}-*.so.*
96 %{_libdir}/%{name}/extensions/*.so*
97 %{_libdir}/%{name}/plugins/*.so*
98 %if %{dbus_type} != "p2p"
99 %{_datadir}/dbus-1/services/*SingleSignOn*.service
100 %endif
101 %exclude %{_libdir}/gsignond/extensions/*.la
102 %exclude %{_libdir}/gsignond/plugins/*.la
103 %config(noreplace) %{_sysconfdir}/gsignond.conf
104
105
106 %files devel
107 %defattr(-,root,root,-)
108 %{_includedir}/%{name}/*.h
109 %{_libdir}/lib%{name}-*.so
110 %{_libdir}/lib%{name}-*.la
111 %{_libdir}/pkgconfig/%{name}.pc
112 %if %{dbus_type} != "p2p"
113 %{_datadir}/dbus-1/interfaces/*SSO*.xml
114 %endif
115
116
117 %files doc
118 %defattr(-,root,root,-)
119 %{_datadir}/gtk-doc/html/gsignond/*
120
121
122 %changelog
123 * Thu Aug 22 2013 Amarnath Valluri <amarnath.valluri@linux.intel.com>
124 - Release 0.0.3
125 - Bug fixes in UI interaction
126 - Documentation support
127
128 * Mon Jun 24 2013 Imran Zaman <imran.zaman@intel.com>
129 - Release 0.0.2 that comprises of bug fixes
130
131 * Wed Jun 12 2013 Jussi Laako <jussi.laako@linux.intel.com>
132 - Prepare for first release
133
134 * Thu Feb 08 2013 Jussi Laako <jussi.laako@linux.intel.com>
135 - Initial RPM packaging
136