Merge branch 'daemon' of https://code.google.com/p/accounts-sso.gsignond into daemon
[platform/upstream/gsignond.git] / dists / rpm / gsignond-suse.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type session
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.1
10 Release: 9
11 Group: System/Daemons
12 License: LGPL
13 Source: %{name}-%{version}.tar.gz
14 Requires: dbus-1
15 Requires(post): /sbin/ldconfig
16 Requires(postun): /sbin/ldconfig
17 BuildRequires: pkgconfig(dbus-1)
18 BuildRequires: pkgconfig(gtk-doc)
19 BuildRequires: pkgconfig(glib-2.0) >= 2.30
20 BuildRequires: pkgconfig(gobject-2.0)
21 BuildRequires: pkgconfig(gio-2.0)
22 BuildRequires: pkgconfig(gio-unix-2.0)
23 BuildRequires: pkgconfig(gmodule-2.0)
24 BuildRequires: pkgconfig(sqlite3)
25
26
27 %description
28 %{summary}.
29
30
31 %package devel
32 Summary:    Development files for %{name}
33 Group:      Development/Libraries
34 Requires:   %{name} = %{version}-%{release}
35
36 %description devel
37 %{summary}.
38
39
40 %prep
41 %setup -q -n %{name}-%{version}
42 #gtkdocize
43 # for repository snapshot packages
44 #aclocal
45 #autoheader
46 #libtoolize --copy --force
47 #autoconf
48 #automake --add-missing --copy
49 #autoreconf --install --force
50 # fore release source packages
51 autoreconf -f -i
52
53
54 %build
55 %if %{debug_build} == 1
56 %configure --enable-dbus-type=%{dbus_type} --enable-debug
57 %else
58 %configure --enable-dbus-type=%{dbus_type}
59 %endif
60
61 make %{?_smp_mflags}
62
63
64 %install
65 rm -rf %{buildroot}
66 %make_install
67
68
69 %post
70 /sbin/ldconfig
71 chmod u+s %{_bindir}/%{name}
72
73
74 %postun -p /sbin/ldconfig
75
76
77 %files
78 %defattr(-,root,root,-)
79 %doc AUTHORS COPYING.LIB INSTALL NEWS README
80 %{_bindir}/%{name}
81 %{_bindir}/%{name}-plugind
82 %{_libdir}/lib%{name}-*.so.*
83 %{_libdir}/%{name}/extensions/*.so*
84 %{_libdir}/%{name}/plugins/*.so*
85 %if %{dbus_type} != "p2p"
86 %{_datadir}/dbus-1/services/*SingleSignOn*.service
87 %endif
88 %exclude %{_libdir}/gsignond/extensions/*.la
89 %exclude %{_libdir}/gsignond/plugins/*.la
90
91
92 %files devel
93 %defattr(-,root,root,-)
94 %{_includedir}/%{name}/*.h
95 %{_libdir}/lib%{name}-*.so
96 %{_libdir}/lib%{name}-*.la
97 %{_libdir}/pkgconfig/%{name}.pc
98 %if %{dbus_type} != "p2p"
99 %{_datadir}/dbus-1/interfaces/*SSO*.xml
100 %endif
101
102
103 %changelog
104 * Wed Jun 12 2013 Jussi Laako <jussi.laako@linux.intel.com>
105 - Prepare for first release
106
107 * Thu Feb 08 2013 Jussi Laako <jussi.laako@linux.intel.com>
108 - Initial RPM packaging
109