install: install configuration and set permissions
[platform/upstream/gsignond.git] / dists / rpm / gsignond-suse.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type session
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.2
10 Release: 10
11 Group: System/Daemons
12 License: LGPL-2.1+
13 Source: %{name}-%{version}.tar.gz
14 Provides: gsignon
15 %if %{dbus_type} != "p2p"
16 Requires: dbus-1
17 %endif
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
20 BuildRequires: pkgconfig(dbus-1)
21 BuildRequires: pkgconfig(gtk-doc)
22 BuildRequires: pkgconfig(glib-2.0) >= 2.30
23 BuildRequires: pkgconfig(gobject-2.0)
24 BuildRequires: pkgconfig(gio-2.0)
25 BuildRequires: pkgconfig(gio-unix-2.0)
26 BuildRequires: pkgconfig(gmodule-2.0)
27 BuildRequires: pkgconfig(sqlite3)
28
29
30 %description
31 %{summary}.
32
33
34 %package devel
35 Summary:    Development files for %{name}
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38
39 %description devel
40 %{summary}.
41
42
43 %prep
44 %setup -q -n %{name}-%{version}
45 #gtkdocize
46 # for repository snapshot packages
47 #aclocal
48 #autoheader
49 #libtoolize --copy --force
50 #autoconf
51 #automake --add-missing --copy
52 #autoreconf --install --force
53 # fore release source packages
54 autoreconf -f -i
55
56
57 %build
58 %if %{debug_build} == 1
59 %configure --enable-dbus-type=%{dbus_type} --enable-debug
60 %else
61 %configure --enable-dbus-type=%{dbus_type}
62 %endif
63
64 make %{?_smp_mflags}
65
66
67 %install
68 rm -rf %{buildroot}
69 %make_install
70
71
72 %post
73 /sbin/ldconfig
74 chmod u+s %{_bindir}/%{name}
75
76
77 %postun -p /sbin/ldconfig
78
79
80 %files
81 %defattr(-,root,root,-)
82 %doc AUTHORS COPYING.LIB INSTALL NEWS README
83 %{_bindir}/%{name}
84 %{_bindir}/%{name}-plugind
85 %{_libdir}/lib%{name}-*.so.*
86 %{_libdir}/%{name}/extensions/*.so*
87 %{_libdir}/%{name}/plugins/*.so*
88 %if %{dbus_type} != "p2p"
89 %{_datadir}/dbus-1/services/*SingleSignOn*.service
90 %endif
91 %exclude %{_libdir}/gsignond/extensions/*.la
92 %exclude %{_libdir}/gsignond/plugins/*.la
93 %config(noreplace) %{_sysconfdir}/gsignond.conf
94
95
96 %files devel
97 %defattr(-,root,root,-)
98 %{_includedir}/%{name}/*.h
99 %{_libdir}/lib%{name}-*.so
100 %{_libdir}/lib%{name}-*.la
101 %{_libdir}/pkgconfig/%{name}.pc
102 %if %{dbus_type} != "p2p"
103 %{_datadir}/dbus-1/interfaces/*SSO*.xml
104 %endif
105
106
107 %changelog
108 * Mon Jun 24 2013 Imran Zaman <imran.zaman@intel.com>
109 - Release 0.0.2 that comprises of bug fixes
110
111 * Wed Jun 12 2013 Jussi Laako <jussi.laako@linux.intel.com>
112 - Prepare for first release
113
114 * Thu Feb 08 2013 Jussi Laako <jussi.laako@linux.intel.com>
115 - Initial RPM packaging
116