Release 0.0.3
[profile/ivi/gsignond.git] / dists / rpm / gsignond-0.0.2-10 / gsignond-tizen.spec
1 # define used dbus type [p2p, session, system]
2 %define dbus_type p2p
3 # enable debug features such as control environment variables
4 # WARNING! do not use for production builds as it will break security
5 %define debug_build 0
6
7 Name: gsignond
8 Summary: GLib based Single Sign-On daemon
9 Version: 0.0.2
10 Release: 10
11 VCS:     p/accounts-sso.gsignond/#b31ed6e880b0dcd7635147a57b870c0c137cfce0
12 Group: System/Daemons
13 License: LGPL-2.1+
14 Source: %{name}-%{version}.tar.gz
15 Provides: gsignon
16 %if %{dbus_type} != "p2p"
17 Requires: dbus-1
18 %endif
19 Requires(post): /sbin/ldconfig
20 Requires(postun): /sbin/ldconfig
21 BuildRequires: pkgconfig(dbus-1)
22 BuildRequires: pkgconfig(glib-2.0) >= 2.30
23 BuildRequires: pkgconfig(gobject-2.0)
24 BuildRequires: pkgconfig(gio-2.0)
25 BuildRequires: pkgconfig(gio-unix-2.0)
26 BuildRequires: pkgconfig(gmodule-2.0)
27 BuildRequires: pkgconfig(sqlite3)
28
29
30 %description
31 %{summary}.
32
33
34 %package devel
35 Summary:    Development files for %{name}
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38
39 %description devel
40 %{summary}.
41
42
43 %package doc
44 Summary:    Documentation files for %{name}
45 Group:      Development/Libraries
46 Requires:   %{name} = %{version}-%{release}
47
48 %description doc
49 %{summary}.
50
51
52 %prep
53 %setup -q -n %{name}-%{version}
54 if [ -f = "gtk-doc.make" ]
55 then
56 rm gtk-doc.make
57 fi
58 touch gtk-doc.make
59 autoreconf -f -i
60
61
62 %build
63 %if %{debug_build} == 1
64 %configure --enable-dbus-type=%{dbus_type} --enable-debug
65 %else
66 %configure --enable-dbus-type=%{dbus_type}
67 %endif
68
69 make %{?_smp_mflags}
70
71
72 %install
73 rm -rf %{buildroot}
74 %make_install
75
76
77 %post
78 /sbin/ldconfig
79 chmod u+s %{_bindir}/%{name}
80 groupadd -f -r gsignond
81
82
83 %postun -p /sbin/ldconfig
84
85
86 %files
87 %defattr(-,root,root,-)
88 %doc AUTHORS COPYING.LIB INSTALL NEWS README
89 %{_bindir}/%{name}
90 %{_bindir}/%{name}-plugind
91 %{_libdir}/lib%{name}-*.so.*
92 %{_libdir}/%{name}/extensions/*.so*
93 %{_libdir}/%{name}/plugins/*.so*
94 %if %{dbus_type} != "p2p"
95 %{_datadir}/dbus-1/services/*SingleSignOn*.service
96 %endif
97 %config(noreplace) %{_sysconfdir}/gsignond.conf
98
99
100 %files devel
101 %defattr(-,root,root,-)
102 %{_includedir}/%{name}/*.h
103 %{_libdir}/lib%{name}-*.so
104 %{_libdir}/pkgconfig/%{name}.pc
105 %if %{dbus_type} != "p2p"
106 %{_datadir}/dbus-1/interfaces/*SSO*.xml
107 %endif
108
109
110 %files doc
111 %defattr(-,root,root,-)
112 %{_datadir}/gtk-doc/html/gsignond/*
113