Initial revision
[platform/upstream/curl.git] / curl.spec
1 %define name curl
2 %define version 6.0
3 %define release 1
4 %define prefix /usr/local
5
6 %define builddir $RPM_BUILD_DIR/%{name}-%{version}
7
8 Summary: get a file from a FTP, GOPHER or HTTP server.
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Copyright: MPL
13 Vendor: Daniel Stenberg <Daniel.Stenberg@haxx.nu>
14 Packager: Troy Engel <tengel@sonic.net>
15 Group: Utilities/Console
16 Source: %{name}-%{version}.tar.gz
17 URL: http://curl.haxx.nu/
18 BuildRoot: /tmp/%{name}-%{version}-root
19
20 %description
21 curl is a client to get documents/files from servers, using any of the
22 supported protocols. The command is designed to work without user
23 interaction or any kind of interactivity.
24
25 curl offers a busload of useful tricks like proxy support, user
26 authentication, ftp upload, HTTP post, file transfer resume and more.
27
28 Note: this version is compiled without SSL (https:) support.
29
30 %prep
31 rm -rf $RPM_BUILD_ROOT
32 rm -rf %{builddir}
33
34 %setup  
35
36 %build
37 export CFLAGS=$RPM_OPT_FLAGS 
38 ./configure --prefix=$RPM_BUILD_ROOT%{prefix}
39 make 
40
41 %install
42 make install-strip
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46 rm -rf %{builddir}
47
48 %files
49 %defattr(-,root,root)
50 %attr(0755,root,root) %{prefix}/bin/curl
51 %doc curl.1 README* CHANGES CONTRIBUTE FAQ FILES INSTALL LEGAL MPL-1.0.txt RESOURCES TODO perl/
52