resetting manifest requested domain to floor
[platform/upstream/createrepo.git] / createrepo.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 Summary: Creates a common metadata repository
4 Name: createrepo
5 Version: 0.9.9
6 Release: 1
7 License: GPL
8 Group: System Environment/Base
9 Source: %{name}-%{version}.tar.gz
10 URL: http://createrepo.baseurl.org/
11 BuildRoot: %{_tmppath}/%{name}-%{version}root
12 BuildArchitectures: noarch
13 Requires: python >= 2.1, rpm-python, rpm >= 0:4.1.1, libxml2-python
14 Requires: yum-metadata-parser, yum >= 3.2.29, python-deltarpm
15
16 %description
17 This utility will generate a common metadata repository from a directory of
18 rpm packages
19
20 %prep
21 %setup -q
22
23 %install
24 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
25 make DESTDIR=$RPM_BUILD_ROOT sysconfdir=%{_sysconfdir} install
26
27 %clean
28 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
29
30
31 %files
32 %defattr(-, root, root)
33 %dir %{_datadir}/%{name}
34 %doc ChangeLog README COPYING COPYING.lib
35 %{_sysconfdir}/bash_completion.d/
36 %{_datadir}/%{name}/*
37 %{_bindir}/%{name}
38 %{_bindir}/modifyrepo
39 %{_bindir}/mergerepo
40 %{_mandir}/man8/createrepo.8*
41 %{_mandir}/man1/modifyrepo.1*
42 %{_mandir}/man1/mergerepo.1*
43 %{python_sitelib}/createrepo
44
45 %changelog
46 * Wed Jan 26 2011 Seth Vidal <skvidal at fedoraproject.org>
47 - bump to 0.9.9
48 - add worker.py
49
50 * Thu Aug 19 2010 Seth Vidal <skvidal at fedoraproject.org>
51 - increase yum requirement for the modifyrepo use of RepoMD, RepoData and RepoMDError
52
53 * Fri Aug 28 2009 Seth Vidal <skvidal at fedoraproject.org>
54 - 0.9.8
55
56 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org>
57 - 0.9.7
58
59 * Fri Oct 17 2008 Seth Vidal <skvidal at fedoraproject.org>
60 - add mergerepo -  0.9.6
61
62 * Mon Feb 18 2008 Seth Vidal <skvidal at fedoraproject.org>
63 - 0.9.5
64
65 * Mon Jan 28 2008 Seth Vidal <skvidal at fedoraproject.org>
66 - 0.9.4
67
68 * Tue Jan 22 2008 Seth Vidal <skvidal at fedoraproject.org>
69 - 0.9.3
70
71 * Thu Jan 17 2008 Seth Vidal <skvidal at fedoraproject.org>
72 - significant api changes
73
74 * Tue Jan  8 2008 Seth Vidal <skvidal at fedoraproject.org>
75 - 0.9.1 - lots of fixes
76 - cleanup changelog, too
77
78 * Thu Dec 20 2007 Seth Vidal <skvidal at fedoraproject.org>
79 - beginning of the new version
80