Imported Upstream version 2.86
[platform/upstream/dnsmasq.git] / contrib / Suse / dnsmasq-suse.spec
1 ###############################################################################
2 #
3 # General
4 #
5 ###############################################################################
6
7 Name: dnsmasq
8 Version: 2.33
9 Release: 1
10 Copyright: GPL
11 Group: Productivity/Networking/DNS/Servers
12 Vendor: Simon Kelley
13 Packager: Simon Kelley
14 URL: http://www.thekelleys.org.uk/dnsmasq
15 Provides: dns_daemon
16 Conflicts: bind bind8 bind9
17 PreReq: %fillup_prereq %insserv_prereq
18 Autoreqprov: on
19 Source0: %{name}-%{version}.tar.bz2
20 BuildRoot: /var/tmp/%{name}-%{version}
21 Summary: A lightweight caching nameserver
22
23 %description
24 Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server. It 
25 is designed to provide DNS and, optionally, DHCP, to a small network. It can
26 serve the names of local machines which are not in the global DNS. The DHCP 
27 server integrates with the DNS server and allows machines with DHCP-allocated
28 addresses to appear in the DNS with names configured either in each host or 
29 in a central configuration file. Dnsmasq supports static and dynamic DHCP 
30 leases and BOOTP for network booting of diskless machines.
31
32
33
34 ###############################################################################
35 #
36 # Build
37 #
38 ###############################################################################
39
40 %prep
41 %setup -q
42 patch -p0 <rpm/%{name}-SuSE.patch
43
44 %build
45 %{?suse_update_config:%{suse_update_config -f}}
46 make all-i18n DESTDIR=$RPM_BUILD_ROOT PREFIX=/usr
47
48 ###############################################################################
49 #
50 # Install
51 #
52 ###############################################################################
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 mkdir -p ${RPM_BUILD_ROOT}/etc/init.d
57 make install-i18n DESTDIR=$RPM_BUILD_ROOT PREFIX=/usr
58 install -o root -g root -m 755 rpm/rc.dnsmasq-suse $RPM_BUILD_ROOT/etc/init.d/dnsmasq
59 install -o root -g root -m 644 dnsmasq.conf.example $RPM_BUILD_ROOT/etc/dnsmasq.conf
60 strip $RPM_BUILD_ROOT/usr/sbin/dnsmasq
61 ln -sf ../../etc/init.d/dnsmasq $RPM_BUILD_ROOT/usr/sbin/rcdnsmasq
62
63 ###############################################################################
64 #
65 # Clean up
66 #
67 ###############################################################################
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 ###############################################################################
73 #
74 # Post-install scriptlet
75 #
76 ###############################################################################
77
78 %post
79 %{fillup_and_insserv dnsmasq}
80
81 ###############################################################################
82 #
83 # Post-uninstall scriptlet
84 #
85 # The %postun script executes after the package has been removed. It is the
86 # last chance for a package to clean up after itself.
87 #
88 ###############################################################################
89
90 %postun
91 %{insserv_cleanup}
92
93 ###############################################################################
94 #
95 # File list
96 #
97 ###############################################################################
98
99 %files
100 %defattr(-,root,root)
101 %doc CHANGELOG COPYING FAQ doc.html setup.html UPGRADING_to_2.0 rpm/README.susefirewall
102 %doc contrib
103 %config /etc/init.d/dnsmasq
104 %config /etc/dnsmasq.conf
105 /usr/sbin/rcdnsmasq
106 /usr/sbin/dnsmasq
107 /usr/share/locale/*/LC_MESSAGES/*
108 %doc %{_mandir}/man8/dnsmasq.8.gz
109 %doc %{_mandir}/*/man8/dnsmasq.8.gz
110
111