Update recipes
[scm/bb/meta-tizen.git] / classes / metatizen.bbclass
1 python () {
2     if bb.data.inherits_class('rootfs_rpm', d):
3         rootfsdepends = d.getVarFlag("do_rootfs", "depends", True)
4         rootfsdepends = rootfsdepends.replace("rpmresolve-native:do_populate_sysroot", "")
5         d.setVarFlag("do_rootfs", "depends", rootfsdepends)
6     if bb.data.inherits_class('image-live', d):
7         bootimgdepends = d.getVarFlag("do_bootimg", "depends", True)
8         bootimgdepends = bootimgdepends.replace(d.expand("${INITRD_IMAGE}:do_rootfs"), "")
9         d.setVarFlag("do_bootimg", "depends", bootimgdepends)
10 }
11
12 DIRFILES = "1"
13 RPM_EXTRA_PKGDATA = "1"
14
15 def package_rpm_extra_pkgdata(splitname, spec_file, d):
16     if d.getVar('MANIFESTFILES', True):
17         spec_file.append('%%manifest %s' % d.getVar('MANIFESTFILES', True))
18