Rework URB API naming
[platform/upstream/libusb.git] / TODO
1 high priority
2 =============
3 cancellation race concerns - better tracking of kernel feedback?
4
5 for 1.0
6 =======
7 API docs
8 isochronous endpoint I/O
9 thread safety
10 abstraction for cross-platform-ness
11 error codes
12 fixme review
13
14 for 1.1 or future
15 ==================
16 optional timerfd support (runtime detection)
17 notifications of hotplugged/unplugged devices
18 use poll() rather than select()?
19
20 1.0 API style/naming points to reconsider
21 =========================================
22
23 struct libusb_(bulk|control)_transfer or parameters?
24 devh in general
25 separate transfer allocation and submission
26 config struct/function naming
27 typedef _cb or _cb_fn or _cb_t?
28 typedef as-is or pointers? libusb_dev_t rather than libusb_dev *?
29 remove "_transfer" from libusb_{control,bulk}_transfer_request?