Rename libusb_poll() to libusb_handle_events()
[platform/upstream/libusb.git] / TODO
1 for 1.0
2 =======
3 cancellation race concerns - better tracking of kernel feedback?
4 thread safety
5 error codes
6 fixme review
7 review functionality missing over 0.1
8 endianness of control setup, issues when resubmitting transfers
9 make libusb_get_pollfds return const?
10 doxygen warnings
11 make descriptor things const?
12 isochronous sync I/O?
13
14 1.0 API style/naming points to reconsider
15 =========================================
16 typedef _cb or _cb_fn or _cb_t?
17 typedef as-is or pointers? libusb_dev_t rather than libusb_dev *?
18
19 for 1.1 or future
20 ==================
21 optional timerfd support (runtime detection)
22 notifications of hotplugged/unplugged devices
23 use poll() rather than select()?
24 offer API to create/destroy handle_events thread